Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (ryan387)      Join Date: Mar 2004       08-02-2010, 6:22 PM Reply   
Hey I will post up pics later but I was wondering if anyone had some advice first. I have a 2003 supra ssv and it seems to be running a bit rich. I pulled off the flame arrestor and it looks like the injectors are spraying good, but it doesn't look like they are misting evenly. You can see where more fuel is building up in places. I will attach a pic of this later. Also, because of the excess fuel, its like the engine is flooded. In order to get it to start, I have to take it out of gear and open it all the way up to clear the excess fuel, then come off the throttle. Are there any quick adjustments I could make or am I going to have to have my injectors taken off and cleaned? Maybe run some injector cleaner through? I am at a loss, so thanks in advance.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:50 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us