Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (smithlsv)      Join Date: Feb 2007       08-01-2010, 9:20 PM Reply   
I have an 08 21v with around 320 hours on it. I was on the lake this last weekend and put gas in on the water. The boat ran fine prior to filling. I made a trek accross the lake and noticed that the boat would more less surge when trying to go over about 35mph. Later that evening the boat died as I tried to start it. Took it out and filled up all the sacks and noticed it took forever to get on plane. On my way back to teh dock the service engine light came on and was surging again. I just put a new prop on last weekend and rode all last weekend no problems the rode all day before putting in gas just fine. What do you guys think?


Fuel filter?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:17 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us