Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Wakeboarding Discussion

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (wakeboardlf25)      Join Date: May 2007       07-30-2010, 3:04 PM Reply   
is anyone else having problems with CWB new 6 in. baseplate. i have had 2 brand new AA boots with this baseplate and on about 3 or 4 separate occasions the screws will stay in place fine but the boat will complete move from its position and sometimes completely off the board. The new "claw" screw ins start the grind up the rubber teeth on the base plates and ruin them. I check my screws and the claws every time before i ride to make sure there secure but on bad falls the boot will come off while the screws stay in place. the life span of my first pair of AAs was about 6 sets, and the span before it happened on my new ones was only one set. just wondering if this happens to anyone else.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:27 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us