Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (hawk22)      Join Date: Jul 2006       07-28-2010, 11:53 AM Reply   
the acronym holds true...

I took a trip this past week. Headed over the pass to some warmer weather in Spokane, WA. when I arrived at the boat launch I went to put my boards on the racks and I am missing one rack. i felt like I was being punk'd. I'm not sure if someone jacked it while I was in a store, but then why wouldn't they have taken the other one? So my guess is it somehow fell off during travel...I hope it was maybe over small bump in town somewhere and not wiggled loose goin 70 on the hwy. that coulda been ugly. Whatever! I'm over it. I had to get a little creative with surf and wakeboard stacking but we made it work...

We were only there for 2 days because we were heading to another lake with some other friends. So our last morning we were surfing and some people were complaining about the gas smell. I didn't think much of it, sometimes its more noticeable than others. I pull the boat out of the water to find my FAE hanging off one side. It had come loose off one of the exhaust ports AND broke the all-thread support on that one side. I'm pretty confident I didn't hit anything. Never felt anything and no other evidence anywhere. But I guess I could have??? Or maybe it had to do with lots of tubing? I really don't like tubing but 6 kids 11 and under...we did a fair share of tubing.

My first thought was just to remove it, but then I realized I didn't even have my exhaust covers to put on in its place. It ended up being a pretty simple fix, just stopped by a home depot and got some new all-thread and nuts and washer and when we got to the next lake reinstalled the FAE. Whew!

We stay at the next lake for 3 days (Blue Lake), had a great time. We finally get home late Monday night and I notice a tear in my cover. One of my boards somehow penetrated the cover. I wanted to blame my wife because she loaded it this time, but they were seemingly in the same spots I store them when we travel so not sure whey this time was different, but needless to say...this was probably my worst travel experience with boat.

If anybody finds a Mako board rack on I-90, send it my way...

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:07 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us