Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (dave27)      Join Date: May 2005       07-12-2010, 9:10 AM Reply   
So I just got back from the Dirty-D dropped my dad off at his bar in Sunnyvale, had a beer, then went out to my truck to drive the last 7 miles home. When I get to my truck I noticed a huge puddle of oil on the ground. I further investigated and found that it was my truck leaking the oil. The whole undercarriage was covered from the back of the bell housing all the way to the back of the truck. There was so much oil. I checked the dip stick and no oil registered. I heard no signs of this problem at all. I hope I have no other damage. My first guess was a broken rear main seal. But rear seals don't just fail all the way. So for now, I think its the HPOP (high pressure oil pump line) that has failed. I won't find out until tuesday what the real problem is b/c the Diesel tech doesnt work today. Anyone else have had this problem?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:56 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us