Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (ian_ashton)      Join Date: Jul 2008       06-04-2010, 10:29 AM Reply   
After laying out my custom design I anxiously waited for about a month to have it made, and when it showed up I couldn't wait to get the thing installed! I went out last night and got the job done, and I have the blisters to prove it!

Removing the old pad was easier than I thought, but getting all the leftover adhesive was a bit of a pain. I used mineral spirits and elbow grease, took about 45 minutes.

I did all this with the boat in the water, which was a little tricky, but not too bad.

On with the pics!

(Sorry for the crappy iPhone quality, I forgot my normal camera at home.)
Attached Images
       

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:08 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us