Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (fullmoonplatoon)      Join Date: May 2010       05-31-2010, 3:59 AM Reply   
Has anyone out there EVER heard/seen this:

a blade--a single blade--of a 4-blade solid BRASS prop just breaking off?!

Now, if you're going to say something like "well, you must've run something over," then to that I ask you: what on earth could we have run over that didn't affect any of the other blades at all? Here is some additional info:
2008 mastercrap (oops-I mean mastercraft) x-30
cruising in pretty calm lake water, 120 ft. deep, in a straight line at about 30 mph (not at all full throttle) when we heard a noise with engine/boat vibration; sounded & felt like the engine popped off its mount.
We took the boat out & this is what we found...
any feedback would be helpful.
Thanks!
Attached Images
   

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:30 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us