Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (chaser)      Join Date: Sep 2006       05-17-2010, 8:29 AM Reply   
So I want to replace my ballast impellers. Right now I have the yellow for the two rear sacs in my 02 X-star that seem to work OK. I had the black impeller for my kgb and bow, but during spring inspection, I noteced it had two vains that were partially tore so I replaced it with my extra yellow impeller I had. The problem is, the yellow impeller would fill the kgb sac and bow sac, but not have enough pressure to empty it. I put the old black impeller back in and was able to drain the kgb and bow sacs. I've never had problems with my black impeller before, but switched to the yellow due to recommendations here. Now I hear the impellers are green. Stiffness half way between the black and yellow impeller or something like that? Is that the case and if so, where is the best place to get 3 quick. Thanks.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:47 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us