Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (meathead65)      Join Date: Sep 2006       04-15-2010, 11:00 AM Reply   
OK...I fix boats, but leave the truck stuff to the pros...my local dealer has not been any help, but I can't blame him because he can't re-create the issue when he has the truck. 08 F250 PSD, 31K miles, 6" Pro Comp lift, 37"'s on 20"s: Maybe once or twice a day, I lose all power steering assist. When this happens, no noise, pump howling, nothing...just loses all assist. I'll stop, put the truck in park or reverse, back into drive, and the assist is back as if nothing has gone wrong. Fluid is full, looks/smells normal, and there are no know leaks or suspension issues.

Any ideas?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 2:21 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us