Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    L.D. (ldeisel42)      Join Date: Nov 2009       04-03-2010, 3:33 PM Reply   
My cousin just purchased an 05 X star last week.. Today we took it out just to be in the new boat. We where having trouble setting the perfect pass. When we test drove it, I thought I knew how to set it, but today i was having problems. I thought i was suppose to get the boat up to speed then just easy the throttle all the way down, but that wasn't working...Just need a little help.. thanks..
Old    Dennis (denystaucd)      Join Date: Feb 2003       04-04-2010, 9:21 PM Reply   
http://www.perfectpass.com/download/...2005_older.pdf

Try these instructions I think they are correct for the 05 xstar.. Cheers

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:11 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us