Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (stang_killa_ss)      Join Date: Jan 2010       04-03-2010, 4:20 PM Reply   
ok stock speakers in my moomba sounded blown. so i put in a set of 4 Clarions. they sounded good the first outing, then 1 week later they had the same blown sound. so then i spent alot more money on some really nice Kickers. i put those in and tested them imidiatly. same blown sound. crackly, staticy, typical blown sound. haveing shed money on now 8 speakers and still haveing **** sound i was pretty pissed.
then something came to me, all the blown speakers had all come from the left side. so i went out and did a test, turned the balance on the head unit all to the right side. and the right speakers sounded great!, i could crank them and no distortion.

SO what could cause (repeatedly [3x]) the left side speakers to sound blown, even imidiatly after installing them?

ideas? thoughts on what to try or replace?

Last edited by stang_killa_ss; 04-03-2010 at 4:27 PM.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:54 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us