Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (Blackwood61)      Join Date: Mar 2010       03-26-2010, 2:05 PM Reply   
I have been having issues with a leaking shaft seal on my Supreme boat. The issue started 5 months into the 1 year warranty period, and now my warranty is over and I still have the issue. I was told late last year that there might be as many as 70 other boats out there that came from the Fineline factory with the same problem.

The problem was described to me as a failure to grease the shaft seals before the boats left the factory.

I have been working with Supreme boats from the time when my boat was still under warranty, and I'm hopefull I will get this fixed. It just seems to take time to get answers from the boat manufacturing industry.

So my question is two fold: Are there other Fineline product owners out there with this issue, and what have you done to get the issue resolved?


Thanks.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:47 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us