Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (jdancho)      Join Date: Apr 2009       03-24-2010, 12:06 PM Reply   
When I change my oil on my 2009 Supra with the 340 indmar engine I use the drain hose and it come out very slowly, and end up taking about two hours to fully drain the oil. I make sure I run the boat for about 5 minutes to heat of the oil so I'm not sure why it is doing that. My buddies Moomba with the same engine only take 5 minutes to drain all the oil out using the same method.

So I was wondering if anyone have any solution to the problem. Coming up is going to be the third time changing our oil and hopefully will not take as long.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:29 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us