Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Jonathan B (espritv8)      Join Date: Dec 2009       03-22-2010, 4:53 PM Reply   
Hi guys,

I've just bought a dealer repo, it is still new, has 0 hours. It's a 2008 supreme V220 with the black scorpion engine.

I guess i will need to get the oil changed with filter ans gas filter, that's no problem, but since it's a new boat that was never used in two years, what should i look for also? Any part that would need to be changed? any maitenance you would recommend?

thanks for your help!
Old    Ryan (ryanw209)      Join Date: Jan 2010       03-22-2010, 6:24 PM Reply   
I picked up a brand new 2006 dealer repo in June 2009 and drove it straight to the water and started riding. Looking back that probably wasn't the best idea but I just did the 20 hour service(oil change and top off fluids) on it when it came time to. Then changed the oil every 50 hours like usual. I'm at 100 hours now and everything is working just fine
Old    Rich (dohboy)      Join Date: Aug 2007       03-22-2010, 7:00 PM Reply   
Maybe a mechanic can chime in here but when I picked up my boat I was under the impression that the oil that came in the boat was 'break in oil' and needed to be changed after 20 hrs. If thats true you should make sure you put in the right oil first. Of course I could have been told that to make sure I returned for the 20 hour service.
Old    Jonathan B (espritv8)      Join Date: Dec 2009       03-23-2010, 5:18 PM Reply   
Well, from what you are saying, it's seems I was worrying for no reason. Seems pretty basic...

Any other toughts??
Old    UncleJessie (unclejessie)      Join Date: Jan 2004       03-23-2010, 5:20 PM Reply   
IMPELLER!!! Since it has been stuck in ONE position for two years it maight have developed cracking. $20 part can take down your whole motor!

-Uj
Old    Jonathan B (espritv8)      Join Date: Dec 2009       03-23-2010, 6:03 PM Reply   
Your are talking about the bilge pump impeller? Is it easy to change?
Old    Don Christman (ktm525)      Join Date: Mar 2009       03-23-2010, 6:18 PM Reply   
Quote:
Originally Posted by espritv8 View Post
Your are talking about the bilge pump impeller? Is it easy to change?
I am pretty sure the previous guy meant the water intake impeller. They get hard and crack and the no water into the motor.
Old    UncleJessie (unclejessie)      Join Date: Jan 2004       03-23-2010, 8:33 PM Reply   
Yes, the main water intake impeller.
Old    Jonathan B (espritv8)      Join Date: Dec 2009       03-24-2010, 4:08 PM Reply   
I haven't seen the pump yet, boat still in it's original packaging

Is it hard to change? any hints on that? thanks!!!

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:49 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us