Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (hfpesko)      Join Date: Dec 2006       03-02-2010, 7:46 PM Reply   
Im about to upgrade my ballast system in my boat. I have an 05 Vride with the stock 250# tanks in the back and a 500# in the center. My plan is to take the 250s out and replace them with 750s, then piggy back an integrated bow sac off the center tank. However, I was told from a very reliable person that works on a lot of ballast systems (I dont want to use their name) that there have been a lot of problems with the piggy back system. Is this true? Has anyone had an issue with filling or emptying their system? Any info (good or bad) would be awesome!

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 2:13 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us