Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Non-Wakeboarding Discussion

Share 
Reply
 
Thread Tools Display Modes
Old    Ride4Him (jcstudebaker)      Join Date: Feb 2006       01-28-2010, 8:50 AM Reply   
Hey all,
My wife and I just recently (2 weeks ago) bought a 98 accord 150k and we test drove it and everything, it was a really strong car. I know a little about cars, so I felt confident in buying it.

4 days later the Check engine light came on. The car runs completely fine and everything, the only difference in the whole car is my brake light in the back is out. Nothing changed when it came on. I took it to AAMCO and they said it was my ECM, 1,000 to fix. I don't understand how the car can still run fine if the ECM is bad, plus the guy didn't seem to knowledgable about what he was doing either. The Code that came up said Fuel/air mix. Has anyone come accross this, does anyone know someone who is in the Stockton area that's reputable?

I'll find the exact code and post it on here. I just don't understand how the ECM can be out and the car run fine.
Old    John Anderson (fly135)      Join Date: Jun 2004       01-28-2010, 9:22 AM Reply   
I always ignore the light until the car starts running bad.
Old    Nick Tomsyck (sidekicknicholas)      Join Date: Mar 2007       01-28-2010, 10:20 AM Reply   
I would put my bet its on the 02 sensor, Honda's engine light comes all the time because of tha't, and it is a worthless problem that does not need fixing.

My Civic is at 200k and the engine light has been on since 150k... because I knocked my exhaust around (messing up the O3 sensor) and it still runs like a dream
Old    Brad Walker (humboldt9)      Join Date: Jun 2004       01-28-2010, 10:51 AM Reply   
I have the exact same problem with my exact same '98 Honda Accord. It could either be the sensor, or have you filled up the gas tank lately? If you don't turn the gas cap enough the check engine light will come on. This happens all the time with mine. I make sure that every time I fill up I tighten through several "clicks" of the gas cap. It usually takes about 50 miles of driving for the check engine light to reset itself.

You can also try disconnecting the battery to reset the computer; however, you will need the 6 digit code to enter into the radio. IMO... AAMCO is trying to rip you off.
Old    Thomas Deneka (tdeneka)      Join Date: Aug 2002       01-28-2010, 11:02 AM Reply   
'98 means that it is OBDII, so tt is easy to pull the specific code(s).

Gas cap usually throws an evap system code. fuel/air mix is likely O2 sensor, cat, and/or fuel delivery (injectors, fuel pump, fuel filter, etc. altering desired ratio). Go to AutoZone or equivalent and get the actual MIL code, then look it up in a Honda forum (or post it here). An immediate jump to changing computer is a little silly, especially on a Honda.

I would guess this is not a new issue, and that the seller just cleared the CEL for test drive purposes. The fact that it took a few miles to throw a code pretty much confirms any suspicion along those lines (although it could very well be coincidence).

Also, you should find a new mechanic as I suspect he is asking you, in his own language, to grab your ankles.

Most delayed CELs that require a few diving cycles to trip are emissions related, especially if you do not notice any issues with drivability, smoke, etc.

Get the code(s) pulled and report back!!

(wow on my original spelling . . . .)

(Message edited by tdeneka on January 28, 2010)

(Message edited by tdeneka on January 28, 2010)
Old     (fogey)      Join Date: Mar 2002       01-28-2010, 4:20 PM Reply   
V-6? They have a problem with the EGR system getting clogged up. That'll throw a CEL, but it's purely an emissions thing and has no degradation in driveability or performance.
Old    rodney (azwakekid)      Join Date: Apr 2005       01-28-2010, 8:26 PM Reply   
1k for a ecu is nonsence. i could get a used one all day for 50 bucks. but i bet thats not your problem. my guess is an o2 sensor or something either way hondas are super cheap to fix
Old    Jim Zarin (jimmy_z)      Join Date: Jun 2009       01-28-2010, 9:15 PM Reply   
AAMCO= All Automatics Must Come Out

I didnt know they were into ECM's now????
Old    Charles (chas)      Join Date: Feb 2002       01-28-2010, 11:23 PM Reply   
Pull both battery cables off and let sit for 30 minutes or longer and see of it clears the code.
Old    Thomas Deneka (tdeneka)      Join Date: Aug 2002       01-29-2010, 5:52 AM Reply   
You can certainly clear codes easily by disconnecting the juice (although just the negative (black cable) will do the job) for a short time. Press the brake pedal or turn on the lights to bleed any juice faster.

I really recommend pulling the code(s) before clearing it. It is free, and could catch a bigger problem like misfire, etc. Confidence in what this super mechanic says should be low.
Old    Ride4Him (jcstudebaker)      Join Date: Feb 2006       01-29-2010, 12:05 PM Reply   
So update...

The code is DTC P1164 (air/fuel ratio sensor performance problem)

Called Honda dealer and said that AAMCO told me my ECM was going out. The guy at Honda told me that this happens and that it would be 1,500 to change it. The problem I dont have 1,500 to spend. There is an option on the Honda website that they can do a "goodwill" servie and fix ti for free but the assistant manager said that that typically was for cars 5 to 6 years old, not older. Going to call the manager today.

Im gonna try and make extra sure the gas cap is tight.

If I disconnect the power, and clear the code, is there any harm that could come from that or not?


I do think the owner cleared the code it was about 70 miles after owning it that the light came on.
Old    Mark Anderson (puckinshat)      Join Date: Sep 2003       01-29-2010, 12:26 PM Reply   
If it runs fine, go to target and spend $1 on a package of little stickers to put over the light so you don't see it. Problem solved.
Old    Peter_C (peter_c)      Join Date: Sep 2001       01-29-2010, 12:40 PM Reply   
The P code is a manufacturers code and will not show up with a generic scan tool. There will not be anything in Mode $0A either as it is too old of a vehicle. Before clearing any code one should always check both sides of the computer especially the pending codes.

What are the long term fuel trims? This requires a scanner hooked up to know and will tell a lot about how the stoichiometric is doing. If you have a super fast non averaging DSO with a min/max you could at least get an idea if it is switching.

"Most likely" it is just a bad air fuel ratio sensor. It can effect the cat although it is probably failing at that mileage anyhow. It will effect fuel economy if the sensor is failing. You can check Rock Auto dot com to see how much one is.
Old    Thomas Deneka (tdeneka)      Join Date: Aug 2002       01-29-2010, 1:29 PM Reply   
Primary O2 sensors for most hondas are $50-60 for the OEM fit. Secondary should be similar if not less (I usually change both at the same time). It is a really easy fix.

It does look like Honda had issues with ULEV/SULEV ECMs being overly touchy. Looks like they are not "breaking" but just touchy from the start. New O2 sensors alone still might do the trick though.

As far as ~70 miles driven, that seems about right for a tripped emmisions CEL.

My bet is that LTFT is not going to mean much in this case as I am willing to bet the codes were cleared in order to sell the car (and likewise the LTFT). It would be more interesting to see what ECU tests are "not ready" pending additional miles/drive cycles.

As far as the P code being a manufacturers code, I agree, but not sure what you mean about not showing up with a scan tool?? The description may be off, but the code should be accurate . . . .

Honda codes:

http://liam821.com/pix/?path=info&text=honda-ecu-code.txt

(Message edited by tdeneka on January 29, 2010)
Old    Peter_C (peter_c)      Join Date: Sep 2001       01-29-2010, 2:20 PM Reply   
That is NOT an O2 sensor it is an air fuel ratio sensor aka wide band O2. If it is a 2.3L motor the sensor is $137. from Rock Auto Parts. Be careful pulling them out. Sometimes a torch is the best way to preserve the bung. Often times it takes a special socket but it has been a long time since I looked at a '98 Honda so I have no idea if a wrench will work or not. Sockets are pretty cheap.

The LT fuel trims start recoding immediately and can tell a story 15 minutes after started. The readiness monitors are a good thing to check I will agree with that, but how many people have a scanner available to access Mode $05 and Mode $06 to do so? Really both are useless to the OP at this point.

FWIW manufacturer codes generally do not show up on a generic scan tool in Mode $03. Mode $02 the freeze frame data, tells the story of who, what, where, when. They will show up on a scanner that can access the manufacturers side of the computer though.

Upload

What would I do if I didn't have test equipment available? Throw a $137 sensor in and hope it fixes it. Cheaper than spending the $100 to have someone test it to find out it is a sensor. Heck half the people read the codes and buy the parts, which nails it about 80% of the time. Hopefully yours is not in the 20%.
Old    Jim Zarin (jimmy_z)      Join Date: Jun 2009       01-29-2010, 4:15 PM Reply   
If you are working on 199899 A/T model, inspect the part number on the ECM/PCM in the vehicle.

Is the part number 37820-PAA-305?

If YES... all you need is the air/fuel ratio sensor(part#121170)

If NO.....then you need the sensor and ECM/PCM replaced. May have to go the dealer to have the keys reprogrammed if you did this yourself.
Old    Ride4Him (jcstudebaker)      Join Date: Feb 2006       02-05-2010, 12:35 PM Reply   
To all.

This might seem dumb but I have a few questions.

1.Where is the ECM so I can check the part number?


2. Could I possibly go to a junk yard grab one from an accord there and have them re program it?


3.Is there any way for me to get "good consideration"?
Old    Jim Zarin (jimmy_z)      Join Date: Jun 2009       02-05-2010, 1:06 PM Reply   
The ECU is under the carpet on the passenger side under where your feet stretch out. There is an access panel you need to remove after you pull back the carpet. The ECM is under the panel.

Not sure I would take the gamble of having a junkyard ECM work properly, let alone the trouble of finding one.

As for AWA(after warranty assistance)repairs, dealers usually reserve those for customers who regularly do business with them. It never hurts to ask though.
Old    Matt Ritchie (ritchieps190)      Join Date: Aug 2001       02-05-2010, 2:04 PM Reply   
good consideration is usually for original owners who spend money at the dealer to have regular maintenance done. At least those were the paramaters when I worked in teh service department of a ford dealer. As you already know, it's basically for car's that are "just out of warranty".
Old    Ride4Him (jcstudebaker)      Join Date: Feb 2006       02-05-2010, 3:57 PM Reply   
Well the ECM was under the middle consol. I couldn't see the part number.

The smog is still current I Might try to sell it. I'll just tell the next guy what's wrong maybe there is someone who knows a dealer, maybe he can get a deal.

Or I might look more unto junkyard/ eBay ECM.

Opnions?
Old    Trace (trace)      Join Date: Feb 2002       02-08-2010, 12:52 PM Reply   
There are normally a few guys out there (garage/basement shops) that swap cores and repair older PCM's like this. Google it.
Old    Big D (bigdtx)      Join Date: Feb 2005       02-08-2010, 12:59 PM Reply   
the check engine light in my subaru has been in since 1997 - it's a 1990...
Old    Trace (trace)      Join Date: Feb 2002       02-08-2010, 4:27 PM Reply   
That's not very environmentally responsible of you, BigD.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:56 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us