Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 28, 2009

Share 
Reply
 
Thread Tools Display Modes
Old    John OD (oddos2525)      Join Date: Mar 2008       07-03-2009, 1:03 PM Reply   
my boat stays on a dock all summer. I was out on the boat today and my tower speakers were not working. I looked at the amp and the power light was not on. Then it started going in and out of power. I check all connections and fuses and everything is fine. So I think its moisture building up in the amp. I keep it under my passenger side dash next to the battery. This is the first time this has happened. Im up in new england and it has rained everyday for the past 2 months. I dont know if that could have something to do with. So, I was just seeing if anyone has had this problem or have any ideas on keeping the amp from getting moist. Thanks

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:12 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us