Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 08, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    DC9669 (dc9669)      Join Date: May 2005       05-01-2008, 7:20 PM Reply   
Anyone have any idea why on both of my rear speakers the tweeters are not working? They mid and bass work fine just not the tweeters. The front speakers work fine. It is a original equipment Sony in a 2005 Malibu with Polk speakers.
Old    DC9669 (dc9669)      Join Date: May 2005       05-01-2008, 7:30 PM Reply   
I would like to add that these speakers are fed off of the head unit.
Old    BENJAMIN 74 (benjamin_74)      Join Date: Jan 2008       05-01-2008, 7:40 PM Reply   
Pull the speakers, check to see if the connectors are broken from the base to the tweeter. Or they could be smoked... Try connecting the front speakers to the rear leads, this will tell you if it's the head unit on the wires / speakers.

good luck
Old    Mike B (mlb75)      Join Date: Aug 2007       05-02-2008, 1:14 PM Reply   
most likely they're just blown and need to be replaced...
Old    Brit Rider (brit_rider)      Join Date: May 2004       05-02-2008, 1:23 PM Reply   
"most likely they're just blown and need to be replaced..."

Seconded. It won't be the head unit as then the mids wouldn't work either. Check the cross overs (if applicable) but most likely it's time to pull them and replace.

Also though, did Malibu come stock with Polk? I thought they have used Sony, Kicker and Rockford in the past but I was never aware of an affiliation with polk...

My advice would be to hit up wetsounds.com and try out a pair of their 6.5" drivers, otherwise you'd be sure to find a pair of the polks on Ebay as a cheap, direct replacement.
Old    DC9669 (dc9669)      Join Date: May 2005       05-05-2008, 7:45 PM Reply   
There is a master reset switch behind the faceplate. Once I depresssed that we were good to go.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:24 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us