Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    Nate (norcalmalibu)      Join Date: Jun 2004       03-25-2008, 10:15 AM Reply   
My EQ is getting worse and worse its not as smooth and has a delay. I think it is full of dirt and dirty delta air. Its a Zapco SPl4 anyone got any tips on how to clean it?

I was assuming take it apart and use some sort of electrical cleaner let it dry out reassemble.
Old    "G" (grant_west)      Join Date: Jun 2005       03-25-2008, 12:49 PM Reply   
Nate I had a problem with my Arc EQ, It sits in my dash at a angle that would lend it self to water from my fingers running down into the adjustment's and causing a crackling when you turn the knob's

I took the knob's off and was able to spray a electrical cleaner/conditioner into and on the shaft of the adjustment knob. It fixed the problem for a few week's but then the problem was back.

So this electrical contact cleaner may or may not fix or help you. Ultimatley Arc fixed the EQ for free. You wanna try and keep the face of the EQ as dry as you can. So once you get it fixed you might want to use this conditioner to make sure this dosent happen to you again. Its suposed to put a coating on the contacts that stop's rust. Good luck
Old    Nate (norcalmalibu)      Join Date: Jun 2004       03-25-2008, 5:01 PM Reply   
What conditioner are you talking about?

I have that same crackling you are describing, way to much dirt and wet hands on the knobs. I'm going to take it apart this week as my sub knob was going crazy this last weekend out!
Old    Mikeski (mikeski)      Join Date: Aug 2003       03-25-2008, 6:12 PM Reply   
Nate,

I told you how to fix it! Stop by, I have the cleaner in my cabinet.

Mike
Old    Matt (loudsubz)      Join Date: Aug 2001       03-25-2008, 8:36 PM Reply   
MG Chemicals NUTrol or Contact Cleaner with Silicon.

Deoxit and Progold are also great.

Any of these are the ones you want, they are the best
Old    "G" (grant_west)      Join Date: Jun 2005       03-25-2008, 9:15 PM Reply   
I used the Progold
Old    Clubmyke (clubmyke)      Join Date: Aug 2004       03-26-2008, 12:26 AM Reply   
i use zapco symblink transmitter and volume control. works great - can be used with non zapco amps.
Old    Chucktronics...Ryan (chucktronics)      Join Date: Nov 2007       03-27-2008, 7:54 AM Reply   
The unit has a 3 year dealer installed warranty for that kind of problem.very common in this eq regardless of location (more to do with position). How long have you had the unit?If you think too long? I have the contacts at zapco to get it taken care of in a timely manner, no more than mon- fri of any week. let me know if you need the help, ropbert at zapco is super helpful
Old    "G" (grant_west)      Join Date: Jun 2005       03-27-2008, 8:32 AM Reply   
Ryan: Explaine what you talking about when you say (more to do with position)
Andreas has a Zapco Eq in the dash of his X-30 and his is doing the same thing. I thought it all to do with condinsation and or out door dust,
Old    Nate (norcalmalibu)      Join Date: Jun 2004       03-28-2008, 8:42 AM Reply   
whats the mystery behind the unit ryna?
Old    Sam (wake1823)      Join Date: Dec 2005       03-28-2008, 10:06 AM Reply   
I was on the eq, line driver, boost whatever gizmo band wagon for a while, but eventually these sensistve componets start to fail in some way, or you have so much adjustment in yrou system, you can never get it sounding right for a variety of music. IMO, buy a good quality headunit, good quality amps with suffecient power, and make as little adjustment to "boosts" as possible.
Old    Chucktronics...Ryan (chucktronics)      Join Date: Nov 2007       04-01-2008, 1:48 PM Reply   
Sorry for the late response.
Most eq's lately are built were the know come through the backplate as does the illumination. this leaves room for water and other things to get behind and into the pots. Sp-7-sl is built differently and the pot stems come through the backplate and then have a nut covering up the hole. Much better sounding eq ,but you lose functionality. sub level,fade/bal.
Old    Ben (soundbox)      Join Date: Oct 2007       04-01-2008, 4:07 PM Reply   
Nate - Try opening it up first and using the cleaner that Mike is talking about. If Zapco gives you any headaches about it (they shouldn't) we have had them repaired before outside of Zapco. It might be all that bass from your big 6x9s under the dash .

Did you ever get your Wetsounds? If you didn't give me a call, I might have something brewing for you.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:00 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us