Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Wakeboarding Discussion Archives > Archive through November 29, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    jimmy (reachjims)      Join Date: Aug 2007       11-25-2007, 12:20 AM Reply   
i have a ronix frontier with the scout bindings, and the bindings seem to move back and forth (toe to heel) allot. just wondering if this was normal. i double checked all the mounting screws and they are tight. thanks in advance for the info.
Old    VLX Envy (cavlxenvy)      Join Date: Aug 2007       11-25-2007, 10:32 AM Reply   
'07 or '08?
Old    jimmy (reachjims)      Join Date: Aug 2007       11-25-2007, 12:43 PM Reply   
07, the chuckas.
Old    Clint Pruitt (h2oterroristo)      Join Date: Apr 2006       11-25-2007, 12:57 PM Reply   
The baseplates for '07 are faulty. Take them to your pro shop and they'll swap them with new ones for free.
Old    Nick Tomsyck (sidekicknicholas)      Join Date: Mar 2007       11-25-2007, 1:44 PM Reply   
I just bought some small washers that go under the screws, and that stopped mine from twisting...but if you're close a shop I would go there
Old    Will Jiron (chikara22)      Join Date: Oct 2006       11-25-2007, 3:55 PM Reply   
I have tried switching the baseplates and I still have the same problem. Is this something you just have to live with?
Old    Nick Tomsyck (sidekicknicholas)      Join Date: Mar 2007       11-25-2007, 5:11 PM Reply   
Just get some washers between the screws and the baseplate...that got mine tight enough to be stable
Old    jimmy (reachjims)      Join Date: Aug 2007       11-25-2007, 10:29 PM Reply   
sweet thanks for the help, iam gonna try to swap out baseplates if there still under warrenty.
Old    Pat Osborne (CBK) (liquidboarder935)      Join Date: Sep 2007       11-26-2007, 9:13 AM Reply   
The 08 baseplates fixed the prob for sure.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:05 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us