Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Video and Photography

Share 
Reply
 
Thread Tools Display Modes
Old     (stxr_racer)      Join Date: Jun 2006       05-05-2011, 5:08 AM Reply   
Firstly my understanding of sound systems and associated terminology is very basic so please go easy on me:-) As I often do I jumped into my 08 210 today to pump up the sounds and enjoy some of my favorite tunes from the factory Clarion & Polk audio setup. Since day one the system sounded great to me and has performed flawlessly.....until now that is:-( The sound emitting from the cockpit and tower speakers at low volume was ok, distorted at mid volume and unbearable at a higher volume. What would cause this to happen so suddenly (incorrect amp settings, blown amp(s), speakers or faulty head unit/connections??) Also what are crossovers and how do you set these up correctly? Any help is greatly appreciated!
Old     (scottymc261)      Join Date: Mar 2009       05-08-2011, 1:03 PM Reply   
What source are you listing too? does it sound distorted on all sources?
My bet is you where listing to you iPod or some external device that you had too too hot. Turn that down.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:51 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us