Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old     (bcrider)      Join Date: Apr 2006       07-28-2010, 12:23 PM Reply   
I have 2 sets of Tower lights ( front & back facing) the front ones weren't working so I started checking everything.
Ground is good to relay
relay is switching, toggle switch itself is fine
all connections are solid
Ground from switch is good
cable from switch to thru hull is fine and attached

The only thing I have left to check is that maybe the cable within the tower has a warn spot that is arching to the tower itself causing the fuse to blow or the connection from the light bar to the tower cable isn't good but that shouldn't make a difference. My only other thought is maybe the thru hull is bad. Other then that I am at a loss of what the issue could be. Both sets of lights pull power from the same place and are both grounded in the same place or are connected in line.

Any suggestions?
Old     (acurtis_ttu)      Join Date: May 2004       07-28-2010, 12:47 PM Reply   
either some sort of short ( like you mentioned---wire exposed) or battery voltage is very low. Ohms law......if voltage is low, those lights will start pulling a ton of amps to produce clsoe to their output. How big is the fuse?

Do you have an amp meter?
Old     (bcrider)      Join Date: Apr 2006       07-28-2010, 1:17 PM Reply   
30 amp fuse

I do have an amp meter but not the most versed in how to test.
Old     (wake_upppp)      Join Date: Nov 2003       07-28-2010, 6:35 PM Reply   
Wire touching inside the tower wont ground out since the tower isnt grounded. Now a positive and a ground wire inside the tower touching each other certainly will pop the fuse. How long does the fuse last? A little while with lights on or it pops instantly when you turn them on?
Old     (bcrider)      Join Date: Apr 2006       07-29-2010, 8:49 AM Reply   
Pops instantly
Old     (wake_upppp)      Join Date: Nov 2003       07-29-2010, 5:25 PM Reply   
Start checking power wires from the lights back. Run a jumper wire for stretches you cant get to like through the tower. Bypass the plug and tower wiring by connecting the jumper to the fuse and then right to the light and see if it still blows.
Old     (bcrider)      Join Date: Apr 2006       07-30-2010, 9:14 AM Reply   
Thanks Sparky, I ended up just recabling the tower with a new wire. The old wires seem to still be good....no exposed wire anyway. I think it was more of the splice between the tower wiring and the light bar itself. Whomever originally installed the lights used like 8 gauge wire so I had to soder the wires together as I don't have tube connectors big enough and I don't think there was enough of a connection. I stripped back the new wire and wrapped it around and sealed with shrink tubing and double checked the ground. So far all seems to be good again.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:41 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us