Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old     (jroth97gt)      Join Date: Sep 2003       03-29-2010, 5:24 PM Reply   
Hey guys,
I've been in the process of getting my 2000 xstar ready for the upcoming season and I attempted to change out the impeller over the weekend. This is my first attempt in this boat but have done it/seen it done on others. I pulled the cap off the impeller housing easy enough but have had no luck getting the old impeller out. I've pried with a screw driving and yanked with pliers to no avail. Does anyone out there have any words of wisdom that may point me in the right direction? I think I've heard people suggest turning the motor over before, I'm assuming to help break it loose from the housing. Any truth to this?
Thanks in advance!
Old     (dDavid)      Join Date: Mar 2010       03-29-2010, 6:13 PM Reply   
I could never get my impeller out until I got the idea to squirt a little binding lube in the housing. Bump the starter and it will pull right out with a small pair of channel locks. If you will lightly lube the housing when you reinstall it, it'll help there also.
Old     (BoatFreak)      Join Date: Mar 2010       03-29-2010, 6:39 PM Reply   
Check out the How to Change Your Raw Water Pump Impeller on new website that just launched today. You can find the video at http://inboardonline.com/how-to/

Last edited by wakeworld; 03-29-2010 at 7:21 PM.
Old     (jroth97gt)      Join Date: Sep 2003       03-29-2010, 7:06 PM Reply   
I actually tried sparying with wd-40 and letting it sit, still wouldn't budge. I'll try bumping the starter on my next attempt and see if that helps break it loose.
Thanks!
Old     (BoatFreak)      Join Date: Mar 2010       03-29-2010, 7:37 PM Reply   
Well that stinks..our mechanici used the WD40 and came off like a charm... Oh well, Good Luck.
Old     (njskier)      Join Date: Jul 2005       03-29-2010, 11:37 PM Reply   
Try using 2 paint can lid removers after soaking it with WD40. You can also use 2 needle nose pliers.
Old     (bmr82)      Join Date: Jul 2008       03-30-2010, 5:52 AM Reply   
I use two large screw drivers on my 2001 x-star. One on eachside, it's always tuff, mainly because it's hard to lean over the motor that way and hold two scewdrivers at once. But that always worked for me. I have heard of folks using small bearing pullers as well.
Old     (big_poppa_pump)      Join Date: Apr 2002       03-30-2010, 5:05 PM Reply   
I have a 99 Xstar but its a similar setup. There is hardly any room to get back there and get any kind of leverage on that thing but the steps previously posted worked for me.

I use a small needle nosed channel lock that does a pretty good job. I squirt some dish soap mixed with a bit of water all up in that housing and on the impeller, bump the starter a bit, and then with any luck can grab one of the rubber vanes and start pulling.

Then bump the starter again and get it to rotate about 180 degrees and pull again and repeat until it starts coming out. I generally end up totally destroying the impeller in the process of getting it out, but who cares I personally am not going through this process to "inspect" the impeller, I just replace it.

Also, I put a small small dab of the waterproof trailer bearing grease on the splines (the metal part) of the new impeller in hopes that it makes the next removal a bit easier.

I have heard of a few different people making or buying some type of puller for this, I would love one.
Old     (wakesk8er2)      Join Date: Mar 2002       03-30-2010, 7:07 PM Reply   
Jabsco makes an impeller puller that makes it pretty easy. I've got one and it's basically a small gear puller.
Old     (behindtheboat)      Join Date: Aug 2006       03-31-2010, 7:23 AM Reply   
2 flatheads and 5 min of muscle, just did it last night
Old     (denystaucd)      Join Date: Feb 2003       03-31-2010, 8:26 AM Reply   
I use Needle nose vise-grips (http://www.sears.com/shc/s/p_10153_1...1798S43415620P), just don't crimp to tight. They give a solid grip and a surface to get a prybar if needed. But I perfer the soap and bumping the motor method.

Cheers,
DC
Old     (jmanolinsky)      Join Date: Dec 2005       03-31-2010, 9:07 AM Reply   
Two screwdrivers!
Old     (psudy)      Join Date: Dec 2003       03-31-2010, 10:12 AM Reply   
Thats an awesome site. Thanks Natalie.
Old     (jroth97gt)      Join Date: Sep 2003       03-31-2010, 5:13 PM Reply   
I'm gonna take another crack at it saturday morning so thanks for the great advice!
Old     (BoatFreak)      Join Date: Mar 2010       03-31-2010, 9:37 PM Reply   
Thanks so much!

I hope to get some more how to videos up soon. We have about 3 more that have already been filmed, just have to get them edited and posted.

Let me know if there are any how to's videos that we should look into filming in the future.

And Joe next time we do an impeller video, I'll make sure the impeller is difficult to get off



Good night
Old     (burtonrider_77)      Join Date: Aug 2006       03-31-2010, 9:44 PM Reply   
the key is to put some type of never sieze or white lithium grease on the shaft of the pump when you re install it. we do it all the time and never have any type of problem when the boats come back in a year later....

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:44 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us