Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    cu_wakeboard            03-13-2010, 3:58 PM Reply   
I bought a boat a last summer and since then the 3 ballast puppies stopped working. I found out that there was a wiring problem. I then rewired the pumps and am sure that they are getting the correct amount of power. When I turn on the pumps (the boat is not in the water yet), I do not hear anything out of the pumps. However, I do notice that when I turn the pumps on the voltage off of the batteries drops about 1 volt for about 30 seconds and then goes back to normal.

Is this normal? Should the pumps not make any noise whatsoever due to the run-dry system? Or is something faulty with the pumps?

Thanks, Eric
Old     (chpthril)      Join Date: Oct 2007       03-13-2010, 5:19 PM Reply   
Sounds like a bad battery, not a pump problem.
Old    cu_wakeboard            03-13-2010, 5:31 PM Reply   
Quote:
Originally Posted by chpthril View Post
Sounds like a bad battery, not a pump problem.
Should the pumps come on when the boat is out of the water? Or would the Jabsco Run-dry feature keep the pumps from turning on even for a couple seconds?
Old     (chpthril)      Join Date: Oct 2007       03-13-2010, 5:51 PM Reply   
Yes, the pumps will run when out of water.
Old     (tre)      Join Date: Jul 2002       03-13-2010, 5:58 PM Reply   
2nd that. My Jabso ballast puppy pumps will run out of the water.
Old    cu_wakeboard            03-13-2010, 6:54 PM Reply   
Quote:
Originally Posted by tre View Post
2nd that. My Jabso ballast puppy pumps will run out of the water.
And the pumps are clearly audible, correct?

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:49 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us