Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2008

Share 
Reply
 
Thread Tools Display Modes
Old     (05elitevc4)      Join Date: Jan 2008       04-07-2008, 1:58 PM Reply   
I was out this weekend and my bilge kicked on by itself for the fist time ever. Looked in engine compartment and a little water in bottom of boat. Nothing serious, but this boat stays dry unless getting in and out wakeboarding. Didnt look like anything was coming from the engine. Couldnt see any drips or spray. I was pretty stumped. But then it kicked on again so water is coming from somewhere.
Im curious about propeller shaft seal? rudder seal? Anybody have any suggestions? Its an 05' centurion elite v.
Thanks!
And yes I checked the drain plugs.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:12 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us