Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through September 10, 2007

Share 
Reply
 
Thread Tools Display Modes
Old     (lakepirate)      Join Date: May 2007       09-04-2007, 4:44 PM Reply   
I took my boat to beautiful Lake Mead this weekend. The trip and the lake itself were awesome, BUT, I found that the launch ramp we used at one of the marinas was really flat and therefore, had to damn near sink my truck to load/unload. I'd say the water about a quarter up my FRONT tire. So today, I took my truck for a spin and heard what seemed to be an odd sound coming from the motor. Is it possible that going that deep caused a problem to the motor? The truck is running completely normal, just some new sounds. I assume I'd know if something was really wrong, but wasn't sure. Anyone had problems or know about problems with engine/truck damage from loading too deep?

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:31 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us