Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Wakeboarding Discussion Archives > Archive through February 04, 2005

Share 
Reply
 
Thread Tools Display Modes
Old    sublimed            01-29-2005, 9:24 AM Reply   
Hey guys,
I got a pair of 04 Liquid Force Transits. Been using it for around 6 months now and there is rust forming on one particular rivet used to hold the lace loops on the overlay.
I ride in salt water, but rinse off after each session with fresh water. But the point is...all the other rivets are perfectly fine expect for just this one particular rivet. It seems to be made out of a different material from the others.
Now, the whole head of the rivet is totally covered with rust and the rust has goten onto the overlay, causing the overlay to be stained by the rust.
Anyone ever had the same problem or something like that? And any idea if LF would cover this under their warranty?

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:13 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us