WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Waterskiing (http://www.wakeworld.com/forum/forumdisplay.php?f=67732)
-   -   Perfect Pass Settings on 190 (http://www.wakeworld.com/forum/showthread.php?t=84376)

bbeach 09-30-2003 7:27 AM

I've had my PP installed for about a month now and I've had the KX set on zero. This has resulted in what I felt like was a light pull from ball to ball. Recently I skied behind the same year and model boat with the KX set at 100. This pull was much better! I've heard that new boats are set from the factory at 85 KX and I was just wondering what everyone else ran in their KX settings? PX is at zero also since I'm not using the switch.

tacosupreme 09-30-2003 8:48 AM

I'm interested in installing PP in my sportster but I've heard that it over compensates and that the pull is a pain. My bro went behind a brand new Calabria and after every turn, it sped up to compensate but too much then slowed back down. Was it just a poorly calibrated one or are they all like that? <BR> <BR>(Message edited by tacosupreme on September 30, 2003)

bbeach 09-30-2003 9:36 AM

Mine is very smooth, sounds like your bro had the PP set in paddle wheel mode. This is the wakeboard mode and it will surge badly in my experience. If you are running the digital pro and are using the slalom setting running in RPM mode it shouldn't surge.

bbeach 01-20-2004 2:32 PM

What do you guys run your KX settings at?

kstateskier 01-20-2004 3:11 PM

95

boarditup 01-20-2004 5:59 PM

You have to play with it. Try various settings for your particular boat and motor combo. Perfect Pass should be very smooth without surges. It should apply power and block you during your pull.


All times are GMT -7. The time now is 4:50 AM.