WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Ballast Pump not working (http://www.wakeworld.com/forum/showthread.php?t=800988)

Bret 01-27-2014 12:14 AM

Ballast Pump not working
 
So last summer we where up at Tahoe and in the inspection line and when went to show the inspector our ballast one of the pumps wouldn't turn on or work the model is a Jabsco Ballast Puppy 18220-1127 the thing is the original owner replaced the original pump with that one in 2010 does anybody know would could possibly be wrong with it. The boat is a 2004 Ski Supreme Sky Supreme V230.

snork 01-27-2014 5:26 AM

can you hear if the pump switches on if not disconnect and reconnect or look for a fuse or breaker

Pad1Tai 01-27-2014 5:57 AM

It's broke............

After you empty the ballast, always run the pump in the fill direction for a few seconds... A dry pump sometimes will not flip the impeller blades over when dry..
Never had a problem with my 6 jabsco pumps since doing this..

boardman74 01-27-2014 7:42 AM

We are going to need a lot more info then you are giving to help you. Did the pump ever work since you got it? Is there power at the pump? The first thing I would do is make sure you have power at the pump.

bcrider 01-27-2014 9:15 AM

Check power, ground. If it runs and no water pumps then you probably need to replace your impeller. Pull it out and connect it to a battery or battery charger to test.

Bret 01-27-2014 12:23 PM

Here it is we bought the boat in august 2012 and we have never used the ballast because before this we had a 1996 Hydrodyne Grand Sport and didn't know that much about ballast and stuff and how it all worked.

boardman74 01-27-2014 2:47 PM

So your not sure if the pump ever worked since you had it. First thing is to test for power at the pump. Does the pump turn on, just not pump? If you have power then pull the pump and test right to a power source(battery). If you got nothing the pump is junk. If you don't have power at the pump you are going to have to work upstream till you find where you are losing power. If none of what I am saying makes sense, then you probably need to find a dealer to make the repair. These things can be simple repairs and they can be complicated.

chpthril 01-27-2014 6:18 PM

pump needs a ground circuit too, so dont forget that.


All times are GMT -7. The time now is 2:13 PM.