WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Black Scorpion Misfireing (http://www.wakeworld.com/forum/showthread.php?t=798324)

rio_sanger 05-28-2013 3:53 PM

Black Scorpion Misfireing
 
Hi all, it's been some time since I've posted on here, but could use some help diagnosing a new problem. '99 330hp Black Scorpion with 620 hrs. meticulously cared for and maintained. Has always run perfectly since new. This weekend, after starting up and idling a bit, went to pull up a rider and it stuttered and kind of "skips a beat" like it's running on 6 or 7 cylinders. At higher rpm, it is a bit smoother, but still a noticeable misfire and roughness. Pulled some plugs and they looked fine, I had replaced them at 500 hrs. Feels like it might be an injector(s)? Put some injector cleaner in gas and changed fuel filter, but no help. Any ideas? I keep the boat at the river 4 hrs from home so I'd like to try and fix it there and not have to tow it back to a mechanic. Thanks in advance for any advice!

lionel 05-28-2013 4:10 PM

Fuel filters, cap/rotor, plug wires.

baitkiller 05-28-2013 4:10 PM

Cap and rotor. Take a look.

Pad1Tai 05-28-2013 4:34 PM

Second that on cap and rotor..... Seen it b4

rio_sanger 05-28-2013 6:07 PM

Thanks! Cap and rotor sounds like a good place to start, I'm hoping it's something that simple, and not a major problem...

SacSurfer 05-29-2013 7:53 AM

I'd go with the first response, fuel filters and cap and rotor. With that many hours can't hurt to do all those for under 100 bucks

humboldt9 05-29-2013 10:17 AM

When was the last time you swapped out the plug wires? If you're changing the cap and rotor you might consider swapping those out too. Keep us posted on the solution I too keep my boat out at the river and I'm always looking for solutions like these if engine issues happen out there. It's a PITA to tow the boat back mid-season.

ryanw209 05-29-2013 10:56 AM

I agree with cap and rotor. Mine was doing the same around 375 hours. Pulled the cap off and all the contacts were corroded.

williamburell 05-29-2013 11:27 AM

There was a large batch of merc caps that were jacked up just fyi

rio_sanger 05-29-2013 7:50 PM

Bought new cap and rotor today, along with plugs, just in case. Now I can't wait to get back out and see if that solves the problem. I smell a "guys work trip" coming up soon ;)
Thanks for your feedback, I'll keep you posted

Tengles 05-30-2013 4:58 AM

I had a similar issue with my black scorpion. It would hesitate on take off and stall or hunt after backing off the throttle. I replaced all the usual stuff fuel filters, spark plugs and leads the rotor cap and none of this made much difference. Ended up using Subaru top end engine cleaner. You clean the throttle body with it then spray half the cans worth down the vacume line while running it at high idle. this did wonders made it like new and now runs perfect. Not sure if you can get your hands on it over there but a google search should point you in the right direction for a substitute product that does the same job.

rio_sanger 05-30-2013 7:59 AM

Thanks Tengles, I'll find a can of spray cleaner and bring it along.

zap 06-03-2013 8:46 AM

Been there, done that

Cap, rotor and a 1/2 a can of seafoam.... good to go


All times are GMT -7. The time now is 6:15 AM.