WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Wetsounds Bluetooth (http://www.wakeworld.com/forum/showthread.php?t=797930)

loux2 05-04-2013 8:24 AM

Wetsounds Bluetooth
 
Anybody heard any updates on Wetsounds new Bluetooth device? Release date, features, or sneak peaks?

durty_curt 05-04-2013 9:00 AM

i didnt even know they had a device coming out! is this a myth or is something actually in the making?

jrw160 05-04-2013 10:44 AM

Supposed to be out soon. Tim confirmed it a couple of months ago. He said it will be 12v powered with a built in 5v line driver and advanced codecs. It will have a 3.5 input and a remote turn on for the amps.

They are also supposed to have a wireless boat link out soon as well. I don't know anything about it except that it will use the same physical housing as the bluetooth unit.

zacharoo 05-04-2013 1:37 PM

The LED controller is out as of this week...The multiple controller is not available however

wetsounds1 05-04-2013 4:31 PM

Soon. I know not soon enough. We will have two Bluetooth units. The first version will be out soon. This will be the non line driver 12 volt unit that is a perfect add on to a WS-420 or any eq or radio. The other ones mentioned above will be out following. I will update when I get an exact date I can get them on the production line.

Yea, The new RF RGB music controller is shipping. We used the same water proof enclosure as our previous controller however added a new pcb with microphone pick up and new remote with music function so it beats with the music.

The new full line of Wet Wire. RCA cables, amp kits, fuse holders and distribution blocks are also shipping now.

Tim
Wet Sounds

pprior 05-04-2013 6:24 PM

Hey Tim my dealer just ordered my new boat audio stuff yesterday (100% wetsounds) and it's yet to be installed. What if anything do I need to do to make sure I'm ready to have the bluetooth unit added on later - will it just plug into the WS420?

wetsounds1 05-04-2013 6:44 PM

Awesome! Can't wait to see it when it's done.

The BT will plug right into the ws-420. So you won't need to worry About it. It will wire up to power and ground, can tap into same one as 420. And 3.5 jack from BT to 420 aux in.

Tim
Wet Sounds

browneye253 05-04-2013 9:04 PM

Sweet any ballpark on the price for the version that you can addon to an existing 420?

Alleykat 05-05-2013 3:37 AM

There is already something very similar to what Tim is talking about available . See http://www.crutchfield.com/p_822BTRE....html?tp=60560

fman 05-05-2013 11:07 AM

Quote:

Originally Posted by Alleykat (Post 1820354)
There is already something very similar to what Tim is talking about available . See http://www.crutchfield.com/p_822BTRE....html?tp=60560

That looks like a great option, anyone here used it? $50 seems like a very reasonable price.

Dmac420sj 05-05-2013 11:33 AM

Anybody know the range on that

cal2vin 05-05-2013 11:42 AM

Sorry to thread jack but about the line driver BT version. What voltages per outs would it have Tim? And on the subject what voltage does the 420 have? I've been using the aux straight from the 420 and bypassing my head unit but I feel like the per outs are pretty low. Maybe 2 volt?? Would u recommend using the head units aux input for higher preouts or should it not matter?

Sent from my DROID RAZR using Tapatalk 2

jrw160 05-05-2013 12:06 PM

Bluetooth range is around 30 feet

silvermustang35 08-01-2013 7:58 AM

1 Attachment(s)
Looks like its ready...
Wet Sounds is proud to announce our brand new WW-BT-VC. Bluetooth Volume Control. The BT-VC is a universal Bluetooth unit that allows you to add Bluetooth connectivity to any source unit. It is a perfect add on to a WS-420, head unit or a stand alone source unit. Now Shipping. MSRP $74.99

dezul 08-01-2013 8:08 AM

Any clue as to when it will be availible to purchase?

wetsounds1 08-01-2013 8:13 AM

It is shipping now!

Tim
Wet Sounds

dezul 08-01-2013 8:31 AM

Quote:

Originally Posted by wetsounds1 (Post 1836755)
It is shipping now!

Tim
Wet Sounds

Link to url for purchase?

wetsounds1 08-01-2013 8:32 AM

have to call us at 877-938-7757 or ask your local dealer to order one. We will be getting it on the site soon to click to order.

Tim
Wet Sounds

superair 08-01-2013 8:39 AM

any more pictures? Will it pug into the aux input of the 420sq?

wetsounds1 08-01-2013 8:45 AM

I will get pics re sized and up loaded. It has a 3.5 mm output. So all you need to do is jack a 3.5 mm cable from BT unit to aux input on WS-420 and your set. Bluetooth 420!

You can go 3.5 mm to RCA adapter and go right into an amp. or you can go into a head unit that has RCA aux input as well. Or 3.5 mm to a head unit with a 3.5 mm aux input.

Tim
Wet Sounds

superair 08-01-2013 8:48 AM

Can they ship today? would love to have it by this weekend.

Brearly_Mason 08-01-2013 9:15 AM

When does the line driver version come out?

wetsounds1 08-01-2013 9:26 AM

It will still be a little time for the other line driver unit. FYI, There will be a larger version that is more of a head unit replacement device with 3.5 aux inputs for wired, and Bluetooth and RCA outputs with built in line driver.

This unit is perfect for adding to a 420 or head unit. It has good voltage output as well for a stand alone. The line driver unit is built mainly for the UTV market as a head unit replacement.

They are shipping today superair. So will go
Out today. Just let the guys know how fast you need it so shipping makes it to you tomorrow.

Tim
Wet Sounds

jonblarc7 08-01-2013 10:21 AM

You might have already answered this so I'm sorry if you did. My head unit went out the day after I just got done installing my new rev10s so I couldn't even get to hear them while I was boarding the next day.:banghead:

Can this be used as a master volume like the head unit would do for the old ws-420.

So I could purchase a used ws-420 and this BT and not have to worry about the head unit ever again!!!!!!!

DQ 08-01-2013 10:35 AM

Just talked to Grant over at Wet Sounds and he said they were testing the range on it, said they were a good 100' away and still able to control it. I ordered 2 of them for the boat and the ranger. That is awesome range

timmyb 08-01-2013 10:45 AM

Pretty sweet! Now, can you just build bluetooth into the next version of the WS420? Thought I might as well ask...

bryce2320 08-01-2013 6:40 PM

I guess I wont opt for bluetooth on the new boat and will instead run this thru the ws420 :D:D

shawnmdarnell 08-01-2013 9:10 PM

100 foot range, that's pretty awesome if true. The most I've seen for an add-on bluetooth like this was 30 feet. This will be a hot seller for sure!

pprior 08-03-2013 8:29 AM

I bought a 12V powered bluetooth unit (Belkin unit that I've been using. Nice things: no power wire, can pair to multiple devices. It runs output into my aux jack.

Does this new Wetsounds unit need line power? Strange that it needs an adaptor for the ws420 - coming from WS I would expect it would be designed specifically for this.

What other benefits for this vs. the belkin type unit that is 1/2 the price?

scottb7 08-03-2013 10:39 AM

i wish there was a way to compare output level across some of these bluetooth units. even though maybe biased maybe wetsounds can share what comparisons they did to competitor products. I am sure they did some comparisons.

wetsounds1 08-03-2013 11:29 AM

1 Attachment(s)
Blair, you would use the BT-VC into the aux input of the 420. So then you have full bluetooth control into 420 as main source so you would not need a head unit. It would give you redundant volume controls so use the one you like to the best. Set the BT-VC at max and use the phone for up and down. Leave the phone up and use the BT-VC as volume up and down. Leave both at max level and use the 420 as volume. It is just how you prefer to use it.

pprior, Not sure where you read the need for an adapter for the 420. There is no adapter needed. The BT-VC has a 3.5 mm output jack. You simply plug a 3.5 mm to 3.55 mm cable from the BT-VC to the WS-420 aux input. Thats it. Now if you want to use the BT-VC as the main and only source. You would simply need a 3.5 mm to RCA cable (adapter) That would convert the output to RCA and be able to jack right into an amp. For instance, in a cooler speaker or ATV use. The BT-VC is run off 12 volt power. It is hard wired. Most of the others and the one you linked are designed for portable use.

Scott: We have tested many of the BT units on the market. Most as mentioned are made for portable use. Are battery powered. And the range is limited. The sound quality is also lacking. Bluetooth sound quality across products is a HUGE variance. Most we found do not offer the sound quality needed for a high end marine audio system. Fine for some head phones, fine for a factory car radio. But when you are talking about a big boat system. We designed a unit with range, as well as sound quality as the most important aspect of the unit.

I can tell you that we went through many different chips and different board layouts. We are super happy with the sound of the BT-VC and the range.

Here is a shot of it panel mounted. You just unscrew the nut on the back with your hand and drill a small hole and slide it in and you have a dash mount. The silver ring can also be taken off for even smaller dash mount.



Tim
Wet Sounds

tonality 08-06-2013 1:42 AM

Awesome...thanks for all the great info Tim, I've been looking for one of these for quite a while.
Can you give some more info on how youre getting the improved sound quality out of this unit? Are you using AptX encoding or something similar to stream higher bitrates? I really want to snag one of these but am trying to decide if i would rather hold out for a nee HU with it built in...


Quote:

Originally Posted by wetsounds1 (Post 1837089)
Blair, you would use the BT-VC into the aux input of the 420. So then you have full bluetooth control into 420 as main source so you would not need a head unit. It would give you redundant volume controls so use the one you like to the best. Set the BT-VC at max and use the phone for up and down. Leave the phone up and use the BT-VC as volume up and down. Leave both at max level and use the 420 as volume. It is just how you prefer to use it.

pprior, Not sure where you read the need for an adapter for the 420. There is no adapter needed. The BT-VC has a 3.5 mm output jack. You simply plug a 3.5 mm to 3.55 mm cable from the BT-VC to the WS-420 aux input. Thats it. Now if you want to use the BT-VC as the main and only source. You would simply need a 3.5 mm to RCA cable (adapter) That would convert the output to RCA and be able to jack right into an amp. For instance, in a cooler speaker or ATV use. The BT-VC is run off 12 volt power. It is hard wired. Most of the others and the one you linked are designed for portable use.

Scott: We have tested many of the BT units on the market. Most as mentioned are made for portable use. Are battery powered. And the range is limited. The sound quality is also lacking. Bluetooth sound quality across products is a HUGE variance. Most we found do not offer the sound quality needed for a high end marine audio system. Fine for some head phones, fine for a factory car radio. But when you are talking about a big boat system. We designed a unit with range, as well as sound quality as the most important aspect of the unit.

I can tell you that we went through many different chips and different board layouts. We are super happy with the sound of the BT-VC and the range.

Here is a shot of it panel mounted. You just unscrew the nut on the back with your hand and drill a small hole and slide it in and you have a dash mount. The silver ring can also be taken off for even smaller dash mount.



Tim
Wet Sounds


cal2vin 08-06-2013 2:44 AM

Tim,

What is the dimension of the stem of the bt-vc that would go in the hole. I have a couple switches on my dash that arent in use. The holes are circular and this looks like it could possibly fit perfect. I dont know the exact diameter of the hole at the moment. What size hole is required?

Thanks

superair 08-06-2013 12:30 PM

any idea when they will be back in stock?

scottb7 08-06-2013 8:03 PM

i agree it is kind of necessary to get more detailed specs. Like in my case I think I can mount in my glove box, but need to know how much clearance it will need. Not in the dash by the knob, but the other way.

tonality 08-07-2013 7:56 AM

Looks like you would just need a standard size opening...think lighter plug size on the back with a half inch around on the front for that fancy ring if you opt for it.

Quote:

Originally Posted by scottb7 (Post 1837623)
i agree it is kind of necessary to get more detailed specs. Like in my case I think I can mount in my glove box, but need to know how much clearance it will need. Not in the dash by the knob, but the other way.


bruizza 08-07-2013 11:43 AM

I picked mine up last night and it is basically the size of a cigarette lighter like tony mentions. I am debating running mine straight to the 420 or running it to one of the Aux inputs on my radio. Since it has been raining since I picked it up I guess I have some extra time to decide.

wetsounds1 08-11-2013 8:17 AM

Sorry been on the road. To dash mount , you drill a 7/8 hole and the unit mounts by using the threaded nut. It is 2 inches long.

They will be shipping again and back in stock mid week.

I'll get more details and a line drawing up on the site soon. About to get on another plane!

Tim
Wet Sounds

bruizza 08-12-2013 10:44 AM

I got mine installed on Friday. Love it for the most part. However with the 3.5 run from the BT to the 420 I get A LOT of noise in the tower speakers. I even get this noise when I am using the HU with my ipod plugged directly into it. I unplug the 3.5 from the 420 and the noise goes away instantly. The wires to run the BT to an aux input on my HU arrive either today or tomorrow. I hope running it directly to the HU solves the noise issue.

ryanw209 08-19-2013 7:09 PM

Quote:

Originally Posted by bruizza (Post 1838492)
I got mine installed on Friday. Love it for the most part. However with the 3.5 run from the BT to the 420 I get A LOT of noise in the tower speakers. I even get this noise when I am using the HU with my ipod plugged directly into it. I unplug the 3.5 from the 420 and the noise goes away instantly. The wires to run the BT to an aux input on my HU arrive either today or tomorrow. I hope running it directly to the HU solves the noise issue.

Update on this?

theanimal 12-27-2013 1:44 PM

Quote:

Originally Posted by ryanw209 (Post 1840017)
Update on this?

I am having this same issue. I have tried 2 different bt modules to the input side of 2 different head units and I have tons of noise on all of them. However when I go from the bt module straight to the amp it is quiet as a mouse. I am going to try a ground loop isolator and see if that works. I wish Tim would chime in on this and let us know if there have been any othe instances of this and his we can fix it.

chpthril 12-27-2013 2:45 PM

Quote:

Originally Posted by theanimal (Post 1857139)
I am having this same issue. I have tried 2 different bt modules to the input side of 2 different head units and I have tons of noise on all of them. However when I go from the bt module straight to the amp it is quiet as a mouse. I am going to try a ground loop isolator and see if that works. I wish Tim would chime in on this and let us know if there have been any othe instances of this and his we can fix it.

If the noise is not present when you take the BT right to amp, bypassing the head-unit, odds are, its not the BT.

Are ALL the audio components sharing the same battery source?

Does the head-unit have an adjustable AUX sensitivity? If so, lower it and retest.

theanimal 12-27-2013 3:15 PM

I never said the bt had a problem. However it does not play nicely with my head units. I can run a CD player into the head units through the same inputs with no problem but they are running on their own battery power. This is why I want to try a loop isolator to see if it helps. Also I have removed all variables and ran everything straight to the battery terminals and still get the same results. There is no adjustment on the inputs.

chpthril 12-27-2013 3:58 PM

My bad Francis, I thought you were looking for some assistance with your noise issue. Good luck with GLI.

theanimal 12-27-2013 4:07 PM

Lol no biggie man. I am actually looking for assistance in the form of advice if anyone has any. I just wanted to see if Tim had heard of this and what had to be done to fix it. No way bashing product though. I love both of the ones I have in my rzrs but I have to figure out hoe to get them to work with these head units now.

hatepain 12-28-2013 10:58 AM

I've had two of these from WS for my golf cart and both have gone bad, actually the first one never worked but the other did for a little while. I was a little less than impressed, there was noise feedback if underway whether I was listening to music or not and the range was maybe 10' before it would cut out. It has a lot of promise but I'm pretty bummed with it.

wetsounds1 12-28-2013 11:23 AM

Interesting. We have sold a ton of these and have had nothing but positive feedback. The range is 30 feet or more. We have found that in some installs. The BT range is based on location, surrounding metal can block Signal, BT phone being used can effect range. For
Instance. In one of our side by sides. We have it in the dash. Range is awesome. In another one it is installed in an overhead metal roof enclosure. Range is half of the other one. It is not the BT VC. It is the location it is installed and surroundings. This is
a limitation of Bluetooth wireless technology and is the same for any device.

As for noise. You need to make sure the BT unit is sharing the same power and ground as the other audio sources. So radio, 420, amps. All must be sharing the same.

This is most likely why you are seeing noise. Again, we have sold a ton. And have had very little issues. I checked with my tech guys after seeing this thread and they assured me they have not had many calls or failures.

So if your having some issues. The best thing to do is always call us. 877-938-7757. Speak with Rob, Gyver, Simon. They can help
Make sure you are wired up right and check it out.

Tim
Wet Sounds

wakebrdr94 12-28-2013 1:59 PM

I've used a variety of BT devices, and I'm not sure why, but the small "portable". Devices all seem to have very limited capability. It's amazing the difference that most head units with BT built in have better range. Not just head units, but other radio items. I've gone to Costco and there was a kicker ipod dock with BT and I literally had 50+ feet with rows of aisle between me and the unit, no issues. Same with other car HU's, range is awesome. Does anyone know why it's so much better than "portable". Units?

hatepain 12-28-2013 3:19 PM

Tim, yeah I'll call in and get another one sent out. The return was totally painless. It is in a metal body cart so that sounds like it is the problem. I'll make sure to wire it off the same power source as the stereo I'm not certain if that's the case. Thanks for the response. I want it to work great trust me :)

chpthril 12-28-2013 3:52 PM

Quote:

Originally Posted by hatepain (Post 1857187)
I've had two of these from WS for my golf cart and both have gone bad, actually the first one never worked but the other did for a little while. I was a little less than impressed, there was noise feedback if underway whether I was listening to music or not and the range was maybe 10' before it would cut out. It has a lot of promise but I'm pretty bummed with it.

In regards to failing: How are you wiring/powering it in the golf cart? Is it 36V or 48V? Is it wired to 2 batts in the pack or through a converter?

In RE to the noise: Is it your source unit or is there a head-unit? Is there an amp? How are these component wired in in RE to the BT?

theanimal 12-30-2013 3:44 PM

Ok if anyone is interested I got the Ground Loop Isolator in today and hooked it between the BT unit and my Aux input on the head unit and viola....no more noise.
I really dont get this since everything shares a common ground but hey if it works I guess its a good bandaid to try.
Thanks to everyone who offered insight.

chpthril 12-30-2013 5:02 PM

Quote:

Originally Posted by theanimal (Post 1857323)
Ok if anyone is interested I got the Ground Loop Isolator in today and hooked it between the BT unit and my Aux input on the head unit and viola....no more noise.
I really dont get this since everything shares a common ground but hey if it works I guess its a good bandaid to try.
Thanks to everyone who offered insight.

They are truly a band-aid. 9 of 10 cases of noise on boats with dual battery banks, we find the problem lies with the audio gears' B+ drawing off different battery banks, not the ground.

theanimal 12-30-2013 7:07 PM

Quote:

Originally Posted by chpthril (Post 1857332)
They are truly a band-aid. 9 of 10 cases of noise on boats with dual battery banks, we find the problem lies with the audio gears' B+ drawing off different battery banks, not the ground.

Definitely not the case here. This is in a Polaris Ranger and I have gone as far as hooking the head unit and BT by themselves to a totally separate battery just to test. This is not engine whine but just straight up noise that only shows up when a phone is actually connected to the BT unit. If you unpair it then the noise goes away. I am not a fan of Loop Isolators or noise filters but in this case it seems to be my only option. By the way I tried 2 different BT units on 2 different but the same model Aquatic Av IP3b head units with the same results. I think something is wrong in the design of this particular head unit causing the ground issue because it doesn't do it with other units.

Houstonshark 03-03-2014 12:43 PM

Any updates on the reliability and SQ of the WW-VC BT? I have an Apple Airport Express in my boat and use it occasionally for AirPlay, which I have always found to be much better quality compared to BT.

cal2vin 03-27-2014 6:27 PM

TJ I just got a WW-BT-VC today and installed it and I too have the noise in line. I don't even have my tower speakers hooked up and it was even loud on the in boats. I can only imagine how harsh it would be on the towers (REV 10's powered by syn4's). I have the the WS bluetooth hooked into the the 420 SQ. The Wetsounds blue tooth ground and 420 ground are both directly to the stereo bank of batteries with no interruptions. Straight wire. The positive is ran to to the remote wire which comes off the head unit and powers on 3 different amps then runs to the 420SQ remote turn on which is where the bluetooth power wire is tied in to that circuit. I have never had a ground loop hum before adding the BT module. The stock HU could be using the +12v remote signal from the starting bank but it is separated which a stock switch so I don't know how that would be possible. Boat is a 2008 Mastercraft X2 btw. Its only present when the bluetooth is connect and after the phone sleeps it will go off. I have tried on an iPod touch newest gen as well as a Motorola Moto X. Same exact issue. I actually made a video to show the exact nature of my issue. Here is the link: http://www.youtube.com/watch?v=mA3vi...&feature=share

Anyone got suggestions? Ill unhook the starting battery tomorrow and test it to be sure. Don't know how I can remedy this issue

Otherwise the WS-BT-VC looks great, AMAZING range, and actually sounds good when turned up over the noise of the distortion, but I can't imagine thats good on speakers.

chpthril 03-27-2014 6:32 PM

Quote:

The positive is ran to to the remote wire which comes off the head unit
Take the BT's red B+ to the same B+ as the amp, head-unit and 420. Im betting that the problem as that head-unit turn-on is not designed to do that.

cal2vin 03-27-2014 6:43 PM

I had that same concern about the remote turn on not being made to actually power devices. Other than placing a manual switch in line any other suggestions on how to power it on with the stereo. I don't want it to just be on at all times the boats key is on.

cal2vin 03-27-2014 6:44 PM

I have thought relay but I tried that for an underwater light and every time it was turned on it made an AWFUL poppingnoise throughout the whole system

chpthril 03-27-2014 7:11 PM

Cal

Wiring the BT's reb B+ to switched ignition is not the same as wiring it to the same B+ as the amps, head-unit and EQ. You would still have noise. There is no harm in having the BT on when the battery switch is on. But, if you only want it on when the stereo is on, then use a relay that is supplied via the same B+ source as the rest of the audio, then use the head-units turn-on to trigger the relay.

cal2vin 03-27-2014 7:25 PM

When I had a relay on the light that's how it was wired but the relay was really large like 30amp I think automotive relay. I remember it have a loud audible physical click as well as the noise it made in the stereo. Now I should clarify the noise it made through the speakers wasn't a constant hum like a ground loop just a one time pop when the relay was triggered. Maybe a much smaller relay of better quality won't cause such a harsh pop. Plus it will always trigger on before the amps actually come on I would think. I'll try that.

chpthril 03-27-2014 7:35 PM

Cal,

I use 30A Tyco 5-pin automotive relays day in and day out. The relay in itself, should not cause noise. Pops, maybe, but that would be in how its wired.

cal2vin 03-27-2014 7:37 PM

Hmm Ill try it out again and see what happens.

jonyb 03-27-2014 10:24 PM

Calvin - can you tie the BT to the switched red wire on your head unit? I've installed a few of these and never had that type of noise. That's not to say that it's definitely not the BT module though.

If none of these fix it, bring it by and I'll give you another one to try out.

cal2vin 03-27-2014 10:50 PM

John, I probably could but the head unit is on the other side port side and this was the quickest method. Ill probably try the relay option first because all the needed wires are right there underneath the dash. I'm sure this is coming from my wiring not the unit itself. How would I go about finding the switched red wire in the head unit wiring harness? Are you meaning power wire to the headunit? Like the one that would have the fuse in it? I was thinking that is a constant 12+ but I haven't checked.

cal2vin 03-28-2014 10:22 AM

Well I just tried wiring it straight to the batteries. Both bluetooth positive and negative. Still same noise. This is exactly where the amps connect to the batteries. The head unit now is only being used as the remote turn on for the amps and the 420. The 420 and the amps and now the Bluetooth are all ran straight to the stereo battery bank. Any other suggestions? I saw earlier in this thread someone said they ended up using a ground loop isolator. I'd like to know why this sound is happening though. I can't run any more direct. Can I?

cal2vin 03-28-2014 10:36 AM

After rereading this thread it sounds like theanimals issue is identical to mine. May just have to use the ground loop isolator

cal2vin 03-28-2014 10:55 AM

OK sorry for the quad post. I found something interesting. I was in the process of hooking the Bluetooth up to the batteries again. I hooked up the positive and noticed the Bluetooth was on and making the noise without the ground wire being hooked to anything. It was getting ground through the aux cable plugged directly into the 420. I unplugged that and BT unit shut off. So I went ahead and hooked the BT neg up to the batteries and instead of using the 420 aux input I ran the 3.5 mm cable to the headunits aux input and switched the 420 over to main source. This fixed the noise! So somehow my aux in the 420 is grounding out. So i started unplugging RCA one by one. The main input RCA's from the head unit causes the noise. Unplug those and the BT is quiet as can be using the aux input on the 420. So I have no idea why the RCAs from the head unit have this issue. Could be a cheap unit. Its the clarion cmd4 that came with the boat (2008 MC). So I guess I can make it work but it bugs me as to why the RCA coming from the head unit have that noise but only on the Bluetooth


All times are GMT -7. The time now is 5:36 AM.