WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Inboard 350 mag mpi problems please help if you can (http://www.wakeworld.com/forum/showthread.php?t=796478)

ettowake 12-21-2012 2:42 PM

Inboard 350 mag mpi problems please help if you can
 
Whats upppp
My 315horsepower mercruiser is very strong and good til now
but just now with 705Hours an 1,5 year of using it begin to
when in full throtle all the way it lacks fuel in the engine and backs to idle without moving the throtle positionn.. but when not all the way down it goes normally.. my first thought was the Fuel water separator and filter, changed and keeps doing the same thing.. can it be the Fuel Pump doing this? just when the engine really needs the gas it dont work? assuming there are 2 fuel pumps one that without it the engine will not start, and the other for the high end rpms?
apreciate for any help.

boardman74 12-21-2012 2:49 PM

So if you run it at 3/4 throttle it runs great there as long as you like? But as soon as you push it to Full(WOT) it backs down to idle without moving the hand throttle.

If thats the case I would doubt it's a fuel starvation issue. Sounds like the computer to me. Because you'd be fuel starved at 3/4 too. and if it could provide just enough fuel for 3/4 throttle when it backed out at full throttle it should only go down to 3/4, where there's enough fuel. Plus it would surge and spit and sputter as it lost RPM and probably die all the way if it was a fuel starvation issue.

Thats a TBI engine so I doubt its even the fuel pressure regulator. If what I said above it what it's doing I'm 90% sure you have a computer issue.

jagermeister 12-21-2012 2:55 PM

Are you sure this has two electric fuel pumps.. 1 feed and 1 pressure?.. Put a fuel gauge on the MPI manifold and read the pressure.. There's a fitting that it screws onto.. Probably the pump..

bftskir 12-21-2012 8:28 PM

is it going into limp mode? what are your water temp, oil pressure gauges reading?, oil full?

meathead65 12-21-2012 11:42 PM

Failed throttle position sensor would be my first guess. 5 minutes on the laptop would verify it.

meathead65 12-21-2012 11:47 PM

According to the thread title it is a Mag MPI, not a TBI motor.

shelby 12-22-2012 5:46 AM

It would be helpful if you could tell us what year is the boat?

boardman74 12-22-2012 7:19 AM

I see that now meat. I'm still sticking with a computer/sensor issue. If theres fuel for 3/4 then there probably fuel for full. Really need more info and hooking the computer up would more than likely tell you the problem right away without changing a bunch of parts for nothing. Parts changing is never better than diagnosis.


All times are GMT -7. The time now is 7:49 PM.