WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   07 Moomba LSV dies under load (http://www.wakeworld.com/forum/showthread.php?t=796430)

hillbilly 12-14-2012 6:23 PM

07 Moomba LSV dies under load
 
Boat just got a service done......Idles fine, But bogs down /dies under a load.
No codes come up on the computer according to the tech?
Anything I should look for or try?

Thanks.....

wakebordr11 12-14-2012 6:48 PM

How did it run before the service?

Bad gas?
Vacuum line leak?
Fuel filter plugged or bad? Fuel lines? Pump?

mark197 12-14-2012 7:35 PM

I had the same problem with mine after i was screwing around with the blower I found it to be a loose wire on the fuel pump. It would make a connection at idle then as the engine would vibrate the connection would fail and starve it of fuel.

hillbilly 12-14-2012 8:50 PM

Thanks for the tips....Someone else is was using the boat and I was getting things 2nd hand.....I guess it was condensation/water buildup in the fuel they think.
I guess they idled it for about 10 min and a few backfires and it cleaned up.....Guess I should put a new cap/rotor and fuel filter on.

BrettHowell 12-16-2012 6:52 PM

Did you accidentally leave moomba cruise on? It will behave funny if you turned the boat off and on with it still set.

hillbilly 12-16-2012 8:12 PM

I forgot about the cruise issue.....


All times are GMT -7. The time now is 9:50 AM.