WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Poping fuses in the right rear drain pump (http://www.wakeworld.com/forum/showthread.php?t=794622)

jonblarc7 07-20-2012 6:59 AM

Poping fuses in the right rear drain pump
 
2006 24v every time I go to empty my ballast the right rear pump blows a fuse. Luckly I have always had a spare to replace it with and it does fine pumping the whole sac out but the next time I go to the lake the same fuse is blown.

Do you think I have a bad drain pump?

rarasaurus 07-20-2012 7:53 AM

We had that issue. Ours was due to one of our wires rubbing through the coating and once in a while touching metal. I believe it was touching the V drive.

Shawn 07-20-2012 9:30 AM

Had a pump just do the same thing to me...after eliminating it being an electrical issue, tore the pump apart. Motor wasn't seized up, but had some friction and was not spinning freely which caused the pump to overwork and pop the fuse...replaced the pump.

Have also had that happen with lake gunk stuck in the pump or hose restricting the flow.

spencerwm 07-20-2012 10:32 AM

I usually have this issue when an aerator pump is going out. I have seen wiring issues as well but 9/10 it is the pump.

Spencer
EasyBoatCare.com

07-20-2012 10:59 AM

Jabsco? You know what type of impeller it has? I had the problem with mine until I switched to the yellow impellers. Now they are using the green ones which are supposed to be even better than the yellows. They just flip over easier.

jonblarc7 07-20-2012 11:09 AM

Supra doesn't use that kind of pump.

jonblarc7 07-20-2012 11:09 AM

Or at least not back in 06 the new ones do.


All times are GMT -7. The time now is 10:46 AM.