WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   boat only starts when cold by turn key (http://www.wakeworld.com/forum/showthread.php?t=793936)

tonyv420 06-14-2012 10:19 AM

boat only starts when cold by turn key
 
my merc 350mag mpi only starts turn key when its cold,( 04 Avalanche) after its warm, I have to put in neutral and throttle it up in order for it to start. I have already put a new IAC sensor in and it didn't help the problem. I was told maybe a knock sensor. Has anyone had this problem with this same motor? Could it be low fuel pressure? I'm getting real tired of it not starting! Already dumped the h20 out of my water feul seperator. Going to put a new filter in this weekend. Should I be hooking up to the brain and see if the shop can pull any codes?

chpthril 06-14-2012 10:51 AM

Sounds like the CTS (coolant temp sensor) is out of limits. Reads cold when the engine is war. This would create a rich condition when warm and the need to open the throttle when restarting warm. This may not set a code, but reading the live data would nail it.

Low fuel pressure would tend to be more noticeable when cold, when a richer mixture is needed.

The knock sensor would retard the timing a little, but I dont see that effecting starting or idle speed.

augie_09 06-14-2012 11:42 AM

could it be vapor lock?

polarbill 06-14-2012 12:02 PM

It doesn't make sense but I had a similar problem and eventually it just wouldn't start on my 2000 moomba mob v. It ended up being the oil pressure switch. The electric fuel pump was hooked to this so that if the oil pressure got low the switch would open the circuit and kill the fuel pump. Does your boat run fine till you turn it off?

Elliottsx80 06-14-2012 12:29 PM

im with polarbill, i would check the oil level and go with the oil sender. see if its glitching on the gauge. 9/10 times when a coolant temp sen. goes out it will read like -165 or something crazy, which makes the fuel trims max out and it would run super rich. another thing it could be is the cam sensor in the cap. that also controls the fuel, and heat will make them do crazy things. if i was you though. i would by a fuel pressure gauge. there pretty cheap. and check the fuel pressure when your having your problem. if its week. its probably the pump. your looking for anything over 40-45psi. instead of throwing parts at it.

phillywakeboarder 06-14-2012 2:20 PM

My guess is the coolant temp sensor as well. My boat (99 x star) has been doing this for 2 years. I'm getting a code for the temp sensor, but I replaced it and it didn't help. I need to attack the thing with a volt meter but haven't gotten around to it yet. It's my understanding that when you advance the throttle at start with a fuel injected motor it doesn't actually give it more gas, but instead sets the ECM to a "default" starting mode, which overrides the "bad" coolant temp sensor data (assuming that's the problem) and delivers an air/fuel mixture that starts the motor under a wider variety of conditions. Good luck!

tonyv420 06-14-2012 2:55 PM

Wow, guess it could be a couple diff things. Is it bad for the engine that I've been starting it like this?

tonyv420 06-14-2012 2:58 PM

Wow, guess it could be a couple diff things. Is it bad for the engine that I've been starting it like this? Polarbill, yes it runs fine, but when I start it when warm it does smell like its running rich, but just at start

tonyv420 06-14-2012 3:03 PM

I actually tricked it and adjusted my throttle cable, and it started when warm but wanted to idle at like 900-1100 rpm, that's to high I believe

polarbill 06-14-2012 3:13 PM

Quote:

Originally Posted by tonyv420 (Post 1760096)
I actually tricked it and adjusted my throttle cable, and it started when warm but wanted to idle at like 900-1100 rpm, that's to high I believe

Doesn't sound like what I was talking about because what I was talking about would completely shut down the motor. That being said I ws just looking at you might not have an oil pressure switch that controls the fuel pump as it might be controlled through the ECM. The oil pressure switches for the electronic fuel pump might only be on carb engines.


All times are GMT -7. The time now is 8:46 AM.