WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Ballast Tripping Breaker (http://www.wakeworld.com/forum/showthread.php?t=793083)

eubanks01 04-30-2012 9:18 AM

Ballast Tripping Breaker
 
A couple of my automated pumps keep tripping the circuit breaker when I turn them on. It seems to be just two of the four switches that do this and will shut themselves off a couple of seconds after I turn them on every time. These are replacement pumps that had to be wired into the factory system a couple of seasons ago and used to work fine.

Any thoughts about what it might be?

bill_airjunky 04-30-2012 9:30 AM

You should verify the impeller inside the pump is spinning freely. If not, it'll draw too many amps to spin & pop the circuit breaker.

eubanks01 04-30-2012 11:21 AM

Thanks Bill. Can you take apart those Rule pumps?

jarrod 04-30-2012 3:14 PM

I had the same problem after a couple year of use, and after storing the boat for long periods of time. We started flipping the switches back and forth from empty to fill to empty and back to fill before committing to one position, and the problem went away. I hope that made sense.

bill_airjunky 04-30-2012 3:39 PM

The pumps in my Malibu are Piranha 800s. There is a single screw on the top & then the top cap comes off with a twist. The impeller is underneath. I just replaced the drain pump in my mid-ship tank this winter. When I tried to spin the impeller it was frozen solid. I did get it to spin but had to twist pretty hard, which would have obviously taken waaaay too many amps.

I found them on Ebay for about $50 shipped.

spencerwm 05-01-2012 9:22 AM

The pump should come apart easily you can get them cleaned up. If it is gummed up and won't turn it might be time to buy a new one and save yourself the headache. They are only $50.

2003-2011 Malibu Shurflo Piranha Ballast Pump Video


All times are GMT -7. The time now is 8:16 PM.