WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through August 27, 2003 (http://www.wakeworld.com/forum/forumdisplay.php?f=81017)
-   -   MC Ballast pumps... yet again!!! (http://www.wakeworld.com/forum/showthread.php?t=78739)

sonicr1 08-16-2003 4:10 PM

OK, I have been one of the advocates for this set up ('02 X-10). Since MC replaced my impellers, I have had no problems, until last week. The center wouldn't work, and I thought it was stuck, so I opened it up and pulled out the impeller. I turned the pump on, and it wouldn't spin. I turned it manually, hoping to get it unstuck... but it still wouldn't spin on it's own... I could hear a quiet hum, like it was getting power, but it wouldn't spin... ARGHH!!!!!!!! It pisses me off!!!!! Cuzz one of the side pumps is starting to work occasionally, and I'm worried that it is about to die also!!! <BR> <BR>

mikeski 08-16-2003 9:48 PM

Are the pumps in a combustible space (engine compartment or near gas tank)? If not you can go with the Simer pumps from BE Atlas $67 each plus shipping (775-283-2550). They might be more reliable than the Jabsco.

sonicr1 08-17-2003 12:23 PM

They are attached to the transom, behind the engine, so yes, it is combustable space. I guess I will see what the deelership will do to make it right, then if I have to, I will build my own ballast system.

jiving 08-18-2003 10:13 PM

Have the same problem with my 03-X10. Just had the port impellar fixed on Thursday, anxious to see how long it lasts.

debsxstar 08-19-2003 12:41 AM

I just had all three of my impellers replaced and I asked to have a little bit of oil or grease put inside to give it some "slip". It has never worked better! My center locker impeller looked ok but it was kinda stuck. One of my other impellers was pretty jacked up. Well after replacing them and adding the grease I can tell how much easier the impellers can switch directions. (wow! Big difference) I plan to make this a regular maintenance routine. The pumps are fairly easy to get to. Don't forget about it and leave the pump on after the water is finished being pumped out. It will get hot. Think of it like the impeller on you're engine.You don't want to run it dry.

jmccallum 08-19-2003 5:55 AM

I have a Simer pump (almost identical to Jabsco that you guys have). Anyway, I used to use vegetable oil as per manufacturer recommendations. <BR> <BR>I switched to a Silicone based grease (o-ring lub) and it works far better. Lasts long and the pump seems to spin way faster. Big difference! <BR> <BR>So, yes regular maintenance for sure... but a silicone based grease wont attack the rubber and actually soaks in a bit (according to the materials engineer here at work anyway)

sonicr1 08-19-2003 3:55 PM

Yeah, like I said, it wasn't the impellers, after I replaced them they worked fine, but now, the center pump is burnt out.


All times are GMT -7. The time now is 10:15 PM.