WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Wakeboarding Discussion (http://www.wakeworld.com/forum/forumdisplay.php?f=1)
-   -   2010 LF Watson binding footbed? (http://www.wakeworld.com/forum/showthread.php?t=782520)

tailgate 08-09-2010 9:04 AM

2010 LF Watson binding footbed?
 
Every time I pull my foot out of the binding, the foot bed (cushion) starts to com out as well, and I have to fix it before i ride again, pretty annoying on the cable this past week...

Anyone else have experience with this?

I'm thinking about gluing it in to avoid this in the future?

911 08-09-2010 11:36 AM

yeah that's normal.
that's one of the reasons i didn't buy them.
yeah some glue or double-sided tape

kmayotte 08-09-2010 12:23 PM

I have the same bindings with the same problem. The bindings were a bit loose around my foot anyways, so what I did was buy a set of Super Feet foot beds and trimmed them to fit using the bottom of the bindings. Slid them in and it solved both problems. Took away volume so they fit better, and stopped the beds from sliding out. Worth the $35.

http://www.rei.com/product/724375

quik876 08-09-2010 7:10 PM

I had that problem while trying out the CT Vantages earlier this year at a wakecamp, really frustrating trying to put the foot bed back in properly. doesn't help much at all when you've got Sasquatch hands trying to get down inside the binding to flatten it out when it rolled up while pulling my foot out.

phillywakeboarder 08-24-2010 9:22 PM

I have the 2010 Watsons and have the same problem. It's incredibly annoying. I've been riding on Watsons since 2006, but I think this will be my last pair. It seems that they've sacrificed too much durability to save weight. I started the season on a pair of 2010 limiteds but had to exchange them because the laces kept breaking and the quick lace system didn't hold the laces tight and the seams were already coming loose. I have to say that Performance Ski and Surf was AWESOME about the whole thing and did everything they could to make things right.

tampawake 08-25-2010 7:08 AM

Had the same problem with my 09's I sent them back and they sent me 2010's. They have not been as big of an issue but don't know why LF does not sew in the foot bed. What is upsetting is I love the way the Watsons fit and height of the boot. Don't know why LF cant figure this out. Anyone try some sort of glue and get it to work???

tailgate 08-25-2010 11:28 AM

Im trying to figure out what glue to use now, I have some gorilla glue that says its waterproof, but I believe it expands, so hesitant to try that.

Shooter 08-25-2010 11:49 AM

I have never liked gorilla glue. A good two-part epoxy should work. I just dont know if if will eat the foot bed material

tampawake 08-26-2010 7:20 AM

No Gorilla it sucks never had good luck with it.

wakerider111 08-26-2010 8:29 AM

Try shoo goo maybe. (can get it in the shoe isle in wal-marts, usually by the polishes and orthotics

we use shoo goo all the time when repairing tubes. used it on a tube that was slashed with a knife that we found at the lake. now we have fine working 3 person tube

i have used it once to repair a part of my Slingshot driver 2 boots and it worked well

Luker 08-26-2010 10:11 AM

I shoe gooed mine and it worked for now... i'm probably 6 - 8 sets into it


All times are GMT -7. The time now is 2:13 PM.