WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Engine left running when pulling out of water! (http://www.wakeworld.com/forum/showthread.php?t=782497)

wakejunki3 08-08-2010 1:23 PM

Engine left running when pulling out of water!
 
Hi All,

To end an almost perfect day at the lake, my wife forgot to kill the boat engine after driving onto the trailer. I noticed it was still running when I got out of my truck to wipe down the boat (~ 1 minute). The engine temperature was fine and no alarm was going off. I quickly jumped in the boat and turned it off.

This morning, I pulled off the raw water pump and inspected the impeller, which looked good. Actually the impeller was still a wet when I pulled it out.

Other than checking the impeller, are they any other concerns I should be aware of?

Thanks!

Silverbullet555 08-08-2010 1:27 PM

I think you will be fine. I would replace the impeller just to be sure it doesn't fail at a bad time. Other than that, you should be good. imho.

wakejunki3 08-08-2010 1:29 PM

@James - Thanks for the reply....yeah I swamped it with a new one when I inspected and kept the old (which still looks good) as a backup.

kko13 08-08-2010 5:56 PM

Been there wife did that 2 me 2. If impeller is ok your golden........it was the guy that didnt notice until after 30 minutes into is ride home that had issues.

dave27 08-09-2010 8:26 AM

You're money, I wouldn't worry at all.

wakejunki3 08-09-2010 8:46 AM

Cool...I was so scared when it first happened....it took all my might not to tear my wife a new one...but I know she didn't mean to do it :-)

mendo247 08-09-2010 9:02 AM

Happened to me once also a few years back after a long weekend. Never even changed my impeller.


All times are GMT -7. The time now is 5:44 PM.