WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   wetsounds acting crazy ? (http://www.wakeworld.com/forum/showthread.php?t=782301)

wakemaker1 08-02-2010 8:14 PM

wetsounds acting crazy ?
 
After about 1 hour of play my pro 80s that are powered by a kicker 550 X2 stareted to sound very deep like the highs cut out then it would come back to life ?? batteries were fully charged and amp was hot but not going into protection ??? What would make this happen ?

gnat87 08-02-2010 10:37 PM

your hitting a protection mode built in the speakers...mine were doing that after i tuned them so i turned my gains down a little and it stopped. I know it is set very high and it really shouldnt be hit so I wouldnt let it happen alot

david_e_m 08-03-2010 5:49 AM

Its fortunate that the protection circuit is doing its job because it may have saved a tweeter. Revisit the tuning including gains plus any intermediate EQ or component and crossover point. Flatten out any EQ or tone controls and make sure your program material isn't loaded up with a bunch of EQ emphasis. Dirty downloads and burns. Anything like low impedance, low voltage or heat that may be compromising the amplifier's output. Check your full power level without a hint of distortion at rest and without the competition of the engine and movement then use that numeric value on the source or remote as a volume reference as you're pulling. Otherwise you are unable to hear what is full power or beyond when underway.

David
Earmark Marine

wakemaker1 08-03-2010 3:49 PM

my system was installed and tuned by hydrotunes thay said same thing the crossover was going into protection ! going to try and turn gains down a little prob dirty downloads causeing problem and playing it at fullthrottle for hours !!


All times are GMT -7. The time now is 10:08 PM.