WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Boats, Accessories & Tow Vehicles (http://www.wakeworld.com/forum/forumdisplay.php?f=3183)
-   -   Perfect pass problem (http://www.wakeworld.com/forum/showthread.php?t=777276)

zorro 03-07-2010 10:16 AM

Perfect pass problem
 
Hello,
I own a 2002 Xstar with Perfect pass.
Yesterday I used the boat and the Perfect pass gave wrong speed readings.
I try to better explain the problem: at very low speed, that is 0-4.5 mph the
speed reading was correct. Then, as soon as the speed increased the unit
provided false readings, for example at a measured GPS speed of 10.2 the
reading was 20, at 25 it was 52 ans so on. The more the speed increased, the
more the readings were incorrect. All this both with the Perfect pass disengaged
and engaged.
What could be the problem? I did not inspect the paddle wheel since the boat
was in the water, but it seems that the wheel turns freely since at very low
speeds the reading is correct and if it did not turn well the speed reading should be
lower not higher than the actual one (at least I think).
Any suggestion would be of help. I never had such a problem.

wake_upppp 03-07-2010 1:13 PM

I would call PP. They are very helpfull and have heard just about every issue before that you may have. It seems like a sensor/paddle wheel or software issue maybe.

zorro 03-07-2010 1:19 PM

Yes,
I will call them. I forgot to say that in rpm mode it works well.

wakesurfer08 03-07-2010 7:40 PM

My Friends 2003 X2 was doing exactly the same as yours. Come to find out that the paddle wheel was the problem. Only problem we had was that Mastercraft used it's own wiring for the paddle wheel, Perfect Pass told us that we would need to get this from Mastercraft. Has something to do with the wiring harness from the paddle wheel to the display they used. Perfect Pass will be able to answer this better, I just can't remember what the total reason was.

SkySki 03-07-2010 8:44 PM

Sounds like an upgrade to the Stargazer is in order.

zorro 03-29-2010 8:10 AM

Just to update. Perfect Pass answered me in a few hours. Now the problem is to find the Mastercraft engine harness which receives in input the cable from the paddle wheel and splits the signal in two cables that respectively go to the Perfect Pass module and to the tachometer.
Does anyone know where such harness is located in a 2002 Mastercraft X-star?

zorro 03-30-2010 12:59 AM

Any suggestion?


All times are GMT -7. The time now is 9:00 PM.