WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through July 28, 2009 (http://www.wakeworld.com/forum/forumdisplay.php?f=722033)
-   -   V drive light came on... (http://www.wakeworld.com/forum/showthread.php?t=720115)

lakepirate 07-27-2009 12:52 PM

...yesterday. I was out at a local lake, ran the boat for a couple hours (no wake boarding, just putted around the lake most of the day), boat ran great all day, but as I was waiting in the marina for my truck, noticed the red v drive light was on. What's most likely the cause of this? <BR> <BR>BTW, I have an '05 Wakesetter with a Walter V drive. <BR> <BR>Thanks alot!

wakemania 07-27-2009 12:57 PM

Check the fluid level to be sure that is OK.

loudontn 07-27-2009 12:57 PM

Was it on at a stand still? If so, this is normal. If it's on while you're over 1200 RPM's (I think) then you need to check your v-drive oil.

eubanks01 07-27-2009 1:14 PM

Yep, have the same boat and not an issue at all. The light always comes out in idle. I wish the dealer would have told us though because it freaked me out the first time!

alans 07-27-2009 1:15 PM

The red V-Drive light should always be on when idling.

nauty 07-27-2009 1:46 PM

In most boats this light comes on when you are under 1000 rpms. If you are above 1000 rpms and the light comes on then you have something to worry about. Check your owners manual; it should cover this.

puamana 07-27-2009 1:47 PM

As a reminder, if the V-drive requires fluid, it must me non-dergent oil only!

tailgate 07-28-2009 7:06 AM

So a question on the oil, my v-drive takes SAE 30 Non Detergent, but this seems to be the hardest stuff to find... Only place I found it was Napa and it was their house brand... <BR> <BR>What is everyone else using? Sorry for the hijack

loudontn 07-28-2009 7:32 AM

Not sure about your particular v-drive unit, but my '05 24SSV uses Penzoil HD-30, which is basically what lawn mowers use and is readily available most places.

rio_sanger 07-28-2009 8:18 AM

My Walter V-Drive manual says nothing about non detergent. <BR>Been running straight 30w in it for ten years without a problem. <BR> <BR> <BR>And yes, the red light should be on below 1200 rpm <BR> <BR>(Message edited by rio_sanger on July 28, 2009)

bill_airjunky 07-28-2009 8:32 AM

No problem with Napa's house brand. It's Valvoline.

flux 07-28-2009 8:34 AM

Cough.....Owner's Manual.....Cough.

tailgate 07-28-2009 8:47 AM

I got conflicting stories from my owners manuals (Moomba and Walters), one said ND SAE 30, the other was Penzoil HD-30...

mtnsmith 07-28-2009 9:06 AM

My walter manual says non-detergent, it says it on the dipstick too.

rio_sanger 07-28-2009 9:12 AM

SAE 30wHD ~ guess even Walter can't make up his mind <img src="http://www.wakeworld.com/MB/Discus/clipart/crazy.gif" border=0> <BR> <BR><a href="http://www.pearson424.org/manuals/VDrive/pages/Page04_jpg.htm" target="_blank">http://www.pearson424.org/manuals/VDrive/pages/Page04_jpg.htm</a>


All times are GMT -7. The time now is 8:29 AM.