WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through June 28, 2009 (http://www.wakeworld.com/forum/forumdisplay.php?f=711910)
-   -   Help with ballast problem please. (http://www.wakeworld.com/forum/showthread.php?t=709848)

millerda31 06-24-2009 12:15 PM

Greetings all, <BR> <BR>I have an 07 MB B52V23 and I have a problem with the drivers side ballast. <BR> <BR>The pump spins and the impeller is fine but the tank isn't filling with water. Today I removed both check valves and they are operating properly. I also was able to blow through the hoses and found no obstructions. I am really out of ideas. <BR> <BR>I did find one small hole in the hose that runs from the pump to the tank. I removed the hose and plugged one end. Blowing through the other end I was able to feel air escaping from the hole. Would this small hole be enough to cause the tank not to fill by allowing air into the line? <BR> <BR>I did cut the hose back past the hole and reinstalled it but I wont be able to get it in the water until next weekend. <BR> <BR>Any other thoughts? <BR> <BR><img src="http://www.wakeworld.com/MB/Discus/messages/65921/709849.jpg" alt="Upload">

spencerwm 06-24-2009 12:52 PM

Take the fill/drain hose off and turn the pump on. Do you get water shooting out of the pump. Might be an obstruction in the intake. <BR> <BR>Next, hit the fill button and place your finger over the empty thru-hull fitting. If the system is sucking air into the drain hole you should replace the check valve. I came across an MB that had a similar issue. Changed the impeller, pulled the check valves and they all seemed to work. The system put more strain on the check valve and it was failing. <BR> <BR>Also try taking the hose off of your passenger side pump and extending it to see if that pump will fill and drain your drives side ballast tank. <BR> <BR>I guess just try to eliminate everything. Good luck! <BR> <BR><a href="mailto:Specner@wakemakers.com">Specner@wakem akers.com</a>

millerda31 06-24-2009 1:24 PM

Thanks Spencer, <BR> <BR>I was able to blow through the hose that runs to the intake on the bottom of the boat without obstruction so I know it isn't that. <BR> <BR>The through hull fitting for emptying is sucking a bit of air so I guess I'll change out the check valves. <BR> <BR>Can't get the boat in the water til this weekend so I can't try pulling the hose off the pump to see if it is shooting water out. <BR> <BR>I did pull all the check valves and blew through them. The ones from the problem side seem identical to the ones from the working side. <BR> <BR>How long can I run the pump dry before damaging the impeller or burning up the pump? <BR> <BR>Thanks for your suggestions. <BR> <BR>(Message edited by Millerda31 on June 24, 2009)


All times are GMT -7. The time now is 2:56 AM.