WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through June 17, 2007 (http://www.wakeworld.com/forum/forumdisplay.php?f=464977)
-   -   Anyone ever blow a JL W6 or W7? (http://www.wakeworld.com/forum/showthread.php?t=462399)

05mobiuslsv 06-12-2007 10:53 PM

What did it sound like when it was done, and did you have it rebuilt at JL. I'm getting this popping sound out of 2 of my W6's, the other sounds fine. The two that are making sounds were hooked to the same amp, I know they weren't over powered, they were getting about 400-450 rms each. I've never blown a sub in my life so not sure what happened here, surely JL's aren't this weak.

xaggie 06-12-2007 11:02 PM

If they are still hooked to the same amp I'd look there first.

05mobiuslsv 06-12-2007 11:06 PM

I unhooked both of them and tried them on the other amp and they still sounded like A$$.

tonality 06-13-2007 6:57 AM

Not that you're out of range, but keep in mind that it's more dangerous to underpower an amp than it is to overpower it. I've had a w6 that started out in my car in 2002 and is currently in my boat hitting just as hard as the day i bought it, so no, they aren't that weak when installed properly <IMG SRC="http://www.wakeworld.com/MB/Discus/clipart/happy.gif" ALT=":-)" BORDER=0>. What were the gains set to on the amp you had them both on?

05mobiuslsv 06-13-2007 8:24 AM

They were hooked up correctly, gain was about 3/4. If you're talking about underpowering a speaker is dangerous (not sure if you meant sub or amp) that is false and it's a myth. Ask any car stereo shop. If that was the case you'd blow your sub while listening to it any lower than full volume.

tonality 06-13-2007 8:34 AM

Not necessarily sending too little power to it, i'm talking about putting an underpowered amp on a beefy sub, because you'll invariably end up wanting more out of it, and either cranking the gain or the HU and sending one or both of them into clipping and blow your driver. What amp did you have on them? <BR> <BR>EDIT: I see what you meant above, i meant underpowering a sub where i said amp <IMG SRC="http://www.wakeworld.com/MB/Discus/clipart/happy.gif" ALT=":-)" BORDER=0> <BR> <BR>(Message edited by tonality on June 13, 2007)

05mobiuslsv 06-13-2007 12:14 PM

I had them hooked up to a Memphis Power reference 1000 watt amp. The amp was seeing 1.5 ohms. Amp never turned off or anything like that. I'm sure it's not the amp because I hooked the subs up to the kicker sub amp and they still sounded like crap. I'm gonna send them in and get them repaired. I'm sure I had the gain screwed up, I was adjusting it when it was mounted and couldn't really see what I was doing. Lesson learned.

masterxstar 06-13-2007 8:56 PM

go with re xxx bullet proof i have ran 6000 watts to one for 2 min before and it was still good


All times are GMT -7. The time now is 9:26 PM.