WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through December 20, 2006 (http://www.wakeworld.com/forum/forumdisplay.php?f=398151)
-   -   New Xplosion Tower and Wetsounds speakers (http://www.wakeworld.com/forum/showthread.php?t=392592)

moki 11-28-2006 11:36 PM

I just replaced my vintage Tige tower with a new Xplosion tower and added the Wetsounds Pro 485s. I am stoked to get the boat back. It is in California right now getting its extreme makeover. Too bad that I have 5 inches of snow in my yard and won't be able to try it on the water until next spring.

moki 11-28-2006 11:37 PM

Pics<img src="http://www.wakeworld.com/MB/Discus/messages/65921/392595.jpg" alt="Upload">

moki 11-28-2006 11:38 PM

Pic 2<img src="http://www.wakeworld.com/MB/Discus/messages/65921/392598.jpg" alt="Upload">

moki 11-28-2006 11:39 PM

pic 3<img src="http://www.wakeworld.com/MB/Discus/messages/65921/392601.jpg" alt="Upload">

anodyne 11-28-2006 11:53 PM

who makes the Xplosion tower??

greg_sa 11-29-2006 12:10 AM

The tower matches the boat very well! <BR> <BR>What year is your Tige?

moki 11-29-2006 12:16 AM

They are new on the market, based out of <BR>Southern California. Their website is still under construction but it is <a href="http://xplosiontower.com" target="_blank">http://xplosiontower.com</a>. Great guys and an awesome product.

moki 11-29-2006 12:18 AM

Thanks Greg, it is a 2000, I picked it up this year with only 100 hours on the engine.} <BR> <BR>(Message edited by moki on November 28, 2006)

norcalmalibu 11-29-2006 12:45 AM

that tower fits your boat perfectly, but im not a fan how it curves on the top.

lcky275 11-29-2006 6:22 AM

That's a perfect fit. Are you going for the 10' bimini, as well?

moki 11-29-2006 10:44 AM

Lucky275, <BR>Yes,I am going for the 10' bimini. I am going to have the standard bimini and then an extension that can be zipped on.

tparider 11-29-2006 11:27 AM

You're going to love those Wet Sounds! Nice tower too!

bigdtx 11-29-2006 11:31 AM

The swim platform on that site looks pretty cool too.

moki 11-29-2006 2:40 PM

Thanks guys, next steps are hooking up the amps and upgrading my batteries and electrical.

sangerlover 11-29-2006 3:55 PM

What amp are you feeding them with?

froese 11-29-2006 5:00 PM

I'm curious about what amp(s) you're using too. I'm also not a big fan of the curve one the top bar, but the lines of the tower are sweet. That curve, and the way it angles the pro485's out, ought to distribute sound at a nice, wide spread... bring the ear plugs!

mikeski 11-29-2006 5:32 PM

JTW and all, <BR> <BR>Now that I have over 100 hours on my WetSounds Pro-485s and amps I don't mind making a recommendation. These speakers respond extremely well to power. Unfortunately big class A/B power draws heavily on our electrical systems. Class D power does not provide clean enough power, unless it has a another processor to clean things up. I have been using Tripath amplifiers for a couple years now. <BR> <BR>I have had very good luck with this amp on my Pro-485s: <BR><a href="http://www.woofersetc.com/index.cfm?fuseaction=product.display&amp;product_i d=120" target="_blank">http://www.woofersetc.com/index.cfm?fuseaction=product.display&amp;product_i d=120</a> <BR> <BR>It is probably the most cost effective, power efficient readily available to power the WetSounds. <BR> <BR>Other good options include the Arc digital amplifiers, if you want to spend a few more $$.

jon_a 11-29-2006 5:43 PM

Looks good. Wetsounds are definitely the speakers to have right now. So clear and so loud!

moki 12-03-2006 12:57 PM

Hey guys, sorry for the delay in the response, I have been out of town for a few days. I am using the Eclipse XA4000. It is a Class D amplifier, so it does not draw a lot of power, but it is using the Ice Power chip. This new technology gives you full clean sound without the current draw. Here is a link that explains more: <BR> <BR><a href="http://www.icepower.bang-olufsen.com/sw1773.asp" target="_blank">http://www.icepower.bang-olufsen.com/sw1773.asp</a> <BR> <BR>Here is the amp that I am driving it with: <BR><a href="http://www.eclipse-web.com/amp/xa4000.html" target="_blank">http://www.eclipse-web.com/amp/xa4000.html</a> <BR> <BR>Unfortunately, I do not have the amps hooked up yet, so I cannot at this time tell you how well the amp really performs.

moki 12-03-2006 10:20 PM

Mikeski, <BR>You are definitely a wetsounds veteran. Any other tips you can give me on maintenance, lessons learned, etc. <BR> <BR>Thanks in advance

will5150 12-04-2006 10:22 AM

Moki- did the tower go right into the same mounts as the old Metcraft or did you need to do some gel coat work?

moki 12-04-2006 12:18 PM

Will, <BR>The tower went into the same mounts in the front, but I had to fill in the back 2 holes and re-drill. I was expecting all four holes to be filled, but was pleasantly surprised with only 2.


All times are GMT -7. The time now is 9:23 AM.