WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through August 27, 2006 (http://www.wakeworld.com/forum/forumdisplay.php?f=364702)
-   -   2005 X-2 MC won't start (http://www.wakeworld.com/forum/showthread.php?t=358916)

faceplanter69 08-20-2006 10:36 AM

I have a 2005 X-2 at the moment, we were out at the lake yesterday and after running most of the day the boat wouldn't start. I checked the safety teather thing by the driver. It was in place, wasn't bumped or anything. It turns over, fires up for a second and dies. Turned the boat over again and nothing. We sat for a about 15 minutes and started it up and it ran fine. I'm thinking maybe some vapour lock? Took a buddy for a wakeboard and it was ok. I started to get my board on and it didn't start. Same thing. <BR> <BR>I took my board off and gave the fuel pump a couple of little wacks with my fist and the boat started. We headed back to the launch and it died again at the launch. This time I couldn't get it started again. <BR> <BR>I'm thinking fuel pump. I've heard the X-2 (X-1's) don't like to be run out of gas or approach empty. The boat still had a half tank of gas so that shouldn't be the case. It turns over fine it just doesn't sound like it's getting fuel. <BR> <BR>I tried to start it again in the garage and it didn't fire up. <BR> <BR>I'm selling the boat on behalf of a friend the owns a different dealership. What's the warrenty on the MC's 3 years for the engine and fuel pump kind of things? <BR> <BR>Any other suggestions what it may be? The boat has around a 130 hours, I don't know the history of it though. <BR> <BR>Thanks

kstateskier 08-20-2006 11:32 AM

I have some friends with later model MCs and most of them have had issues with the fuel pump. Is anything on the line? A buddy of mine had a Malibu promo boat a couple years ago that they sat the tank on the line at the factory and it wasn't getting gas. Burnt out the pump very quick. We had the same type of problems with our '02 Centurion we had, but it turned out to be an electrical issue. You could shake some wires on the engine and the things would start. It's pretty frustrating. I think the Indmar warranty is three years, don't know if the pump is part of the coverage though.

tazbike 08-20-2006 12:00 PM

Sounds like the fuel pump is related. I had a similiar problem and it was just the wiring to the pump, not the fuel pump itself; something to check.

faceplanter69 08-20-2006 2:46 PM

I'm not as familiar with the MC's as the SAN's and BU's. Does the fuel pump make a pumping sound when you turn the key half way? Kind of like an older car would make? It's not making any sound when I turn it half way?

big_ed_x2 08-20-2006 4:33 PM

Go to your fuel line and you should see a valve that looks like the valve for the tires but there will be a cap on it.open it up and press the little pin.If the gas shoots out after you cranked it a couple seconds....your fuel pump is fine. <BR>If that is the case then check for spark,if gas doesn't shoot out,then your fuel pump is no good.

big_ed_x2 08-20-2006 4:35 PM

Same happen to mine and it was a module for the distribution cap.

faceplanter69 08-20-2006 6:01 PM

Is this what your talking about Ed?<img src="http://www.wakeworld.com/MB/Discus/messages/65921/359031.jpg" alt="Upload"> <BR><img src="http://www.wakeworld.com/MB/Discus/messages/65921/359032.jpg" alt="Upload">

faceplanter69 08-20-2006 6:08 PM

no gas coming out when the boat is cranked. <BR> <BR>Anyone know if these are covered under warranty?

gpalovcak 08-20-2006 7:05 PM

I just had the same problem with my 2000 Mastercraft 205 350 LTR . We were out and the boat just quit. No notice. Would start, idle then quit. We took it home and I tried to listen for the fuel pump and nothing. I cranked it and pushed in the valve on the manifold and no gas. I have it in the shop waiting to get looked at but I think the pump is bad. I hear they are expensive??

lionel 08-20-2006 10:38 PM

Paul, I have an 05 X2. I think that is what Big Ed was talking about. I've heard the same about fuel pumps and filters. What I hear is that the fuel filter only filters with 1/4 of a tank or less. I'm not really sure what your problem is, but if I were to guess, your fuel filter is clogged and it put strain on your fuel pump causing it to fail. I think I'll keep changing my fuel filter every year...

lionel 08-20-2006 10:39 PM

Paul, did you use to have a VRide and a SANTE? Now you have an X2?

big_ed_x2 08-20-2006 10:58 PM

Yeah that's it. <BR> <BR>I would say it should be under warranty.From what I heard from my dealer the fuel pump is around $350-$400+ labor.If the pressure is not high enough,then the fuel filter is clogged but either way get it changed.Being that you have an 05' you are OK.(I think)And don't admit that you ran it out of gas.<img src="http://www.wakeworld.com/MB/Discus/clipart/proud.gif" border=0> <BR> <BR>I have an 04' and ran mine out of gas approx. 7 times in 325hrs and so far so good but they say that is a killer. <BR> <BR>Good luck and keep us posted

taylormade 08-21-2006 5:14 AM

Should be under warranty.

faceplanter69 08-21-2006 6:06 AM

Bryan <BR> <BR>I have a really good friend that owns a BU dealership out of state. When he picks up non BU boats I'll sell them for him so they don't sit on his lot. Works well for me as I get to use the boat until I sell it. I've had this one for a couple of weeks and I just may keep it. Killer boat and wake. If only it would start... <BR> <BR>Thanks for your help.

crs 08-21-2006 1:45 PM

I had the same exact problem with my 2005 X2. It was a defective fuel pump. It should be under warranty.

lionel 08-21-2006 2:00 PM

Seems to be a re-occurring problem. And the in tank fuel pump is supposed to be better? I think Malibu is switching to the in tank fuel pump in 2007.

crs 08-21-2006 2:18 PM

I don't think there is a problem with "in tank Fuel pumps", I think there was a problem with an early batch of pumps in 2005 (at least that's what the mechanic told me). I havn't had any problems since mine was replaced. That was 150 hours ago.

shawman 08-21-2006 4:08 PM

I have a 02 197 and lost a fuel pump this year. I have never run it out of fuel which I was told was a real killer on the Carter pump. The older pumps have a plastic impeller that can bind up. Its easy to tell if the pump is the problem because it starts running when the key is turned on to build up pressure in the system. If you dont hear the pump run then that is the problem.

wiltok 08-21-2006 5:16 PM

Call me paranoid - but after replacing two fuel pumps (my dime - about $500 each with labor), I don't let the fuel go below half. Literally, needle gets close to half and I fill it back up. I understand the fuel is filtered from half a tank on down, and above a half it is either raw fuel or a larger diamater filter (the holes). Also, supposedly the fuel keeps the filter cool - which is why it is bad to run it low. Just my .02...

faceplanter69 08-21-2006 7:55 PM

It was the fuel pump. <BR> <BR>I pretty much have to say WTF though to Mastercraft? They won't warranty the pump because the boat is more than a year old. Pick up date was January 2005. <BR> <BR>Is this the Mastercraft warranty period. One year on this stuff? What a joke. What's Malibu, three years? Nautique is 5 years? MC 1 year. <BR> <BR>Is anyone listening at Mastercraft? One year for something that looks like it's a huge problem?

ronnyboy27 08-22-2006 7:55 AM

I have had a ton of problems with my 04 X2. Bad ballist pumps. damn thing always runs out of gas. Even though I can see that the tank is half full. I heard! Rumor only. That the pick up on the 03 to 05 X2s is in the front of the tank so when you take off with less than half a tank the fuel sloshes back and your engine starts sputtering. Then you have to drive back to the dock at 4 miles an hour. Let me tell you how fun that is when your 10 miles from the dock.

crs 08-22-2006 8:27 AM

If you look at the picture of the fuel tank above, you will see a silver disk with several bolts and a fuel line attached. That is the fuel pump. If you loosen the bolts and remove the pump you will see that the fuel filter snaps on to the bottom of the pump and picks up fuel from the bottom rear of the tank. I don't know about the 03's or 04's, But this picture is definitely an 05. I do know from experience that you can run these tanks completely out of fuel.

lzyboy 08-22-2006 9:21 AM

Ron, <BR> <BR>Check your impellers on your ballast tanks... <BR> <BR>Jabsco used to use a standard rubber impeller that can discengrate if you run your ballast tanks dry for an certain amount of time. MC makes a newer synthetic impeller now (06) that is much more durable... My dealer hooked me up w/ 3 new ones &amp; a spair - very cool - ( plug for SKI WORLD USA ) <BR> <BR> <BR>Lzy

big_ed_x2 08-22-2006 3:51 PM

The pick up is in the back 0f my 04 X2 and when it's out of gas,the tank is dry.


All times are GMT -7. The time now is 1:42 PM.