WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through November 14, 2005 (http://www.wakeworld.com/forum/forumdisplay.php?f=268197)
-   -   My 1st impeller install (http://www.wakeworld.com/forum/showthread.php?t=257111)

sangerlover 09-29-2005 6:12 PM

Ok so I am ready to install a new impeller on my 03 Sanger which has not been done yet at 100 hrs . I am generaly fairly good with my own wrenching and I have searched thru out the engine compartment but I cannot seem to locate where it is . My engine is a 350 MAG MPI . Any help on the location and any advise on the install would be appreciated . <BR>Thanks

gvanorde 09-29-2005 6:22 PM

Follow the inlet hose, it will lead you to the impeller housing.

goinboardn 09-29-2005 8:02 PM

this is where mine is... not sure if this helps. <BR><img src="http://www.wakeworld.com/MB/Discus/messages/65921/257134.jpg" alt="">

joe_788 09-29-2005 8:11 PM

JTW, you're probably having a hard time finding it, because it's in the worst possible place you can imagine. <BR> <BR>Actually, I'm not sure where it is on a V210, but look somewhere in the 2 inches of space between the belts, and the transom. <BR> <BR>My buddy and I changed the impeller on my X2 at 300+ hours (on original impeller!), and it was very, very difficult. <BR> <BR>The key to the whole thing was a long pair of needle nose pliers with a 90 degree bend on the end. <BR> <BR>You'll probably also need somebody with little skinny girl fingers (like my buddy), that can get a hand in there to force the impeller in. <BR> <BR>

sangerlover 09-29-2005 8:31 PM

Thanks for the help . The pic gets me in the right direction .

jarrod 09-29-2005 10:52 PM

Joe, next time try some lube. I personally use two pairs of needle-nose vice grips. Getting the old one out is always a biotch. Putting the new one in should be cake. Especially on an indmar motor. <BR> <BR>Also I have heard but never tried: Someone told me to remove the cover, then turn the key and barely click the motor over. Apparently this helps <BR>dislodge it.

liveoz 09-30-2005 12:24 AM

Actually, pull the safety laynard and crank for a couple of seconds. After spraying some wd40 or something in there for lubrication.

djiali 09-30-2005 3:05 AM

changed the impeller on my 99 moomba (indmar DD) and it was a peice of cake...as a matter of a fact, I did it in 5 mins while the boat was sitting in a "borrowed" slip with the owner wanting to get in.

jarrod 09-30-2005 7:37 AM

great idea troy.

greenpinky 09-30-2005 7:41 AM

Wade, give me some more details on that. Where is it, process, cost, etc? Please email me so we don't hijack this thread. <BR> <BR>Thanks in advance.

acurtis_ttu 09-30-2005 7:55 AM

DD's are a piece of cake, V-drive are a pain. the actual mechanical process of replacnig is easy it's the location of everything on a v-drive. you could change the impeller on a DD in 4 foot sweels if you needed too.

nvsairwarrior 09-30-2005 8:20 AM

JTW, I have the same engine and have replaced it twice. The encircled picture is corrrect but obviously in a D drive. <BR>The book calls for a 2 hour job. The first time I did it in my slip 1 hr 50 min. The second time in my garage 1 hr 10 min. <BR>For me, first remove the serpintine belt from the pully. 2nd, remove the complete water separator filter with it's mounting with it's hoses intact(on the other side of the near white colored rectangular fiber glass board (about 3 x 4 inches) also shown in the pic above). Removing this will give you a lot more room to work in. <BR>3rd, disconnect the 2 hoses and just remove the entire pump. Then rebuild on the bench is easy. I used some binding lube when I put it back together. <BR> <BR>Good luck

liveoz 09-30-2005 9:59 AM

J-Rod, <BR> <BR>Got the idea from Gid (wassup). Makes the job a lot easier.

topside_marine 09-30-2005 10:03 AM

JTW- Good advice from Duane. Remove pump from boat and replace impeller on the bench. Be careful not to overtorque the bolts when you put the pump assembly back together. Use small wrenches or ratchets so you do not overapply force. The material used in the housing can be cracked very easily. Use the binding lube on the interior surface of the housing as well as the impeller. Call me if you get stuck.

kgd 10-03-2005 1:21 PM

I had to do mine twice this year. I am guessing the replacement was either defective or somehow something got sucked in there and toasted the blades. Both of mine where replaced while on the water and took 30 to 45 minutes with less than ideal tools. I also have a v-drive which makes access a pain. I removed the divider in the rear storage area on the side the impeller is located, then removed the belt and then removed the entire pump assembly, only two bolts connecting the bracket to the engine block on the MPI. Disconnect the two hoses from the pump assembly then you can take the assembly out and remove the rest of the bolts to get to the impeller. I had no problems removing or assembling the pump with the new impeller. If your impeller is shot, make sure you get all of the rubber pieces out of the filter unit that the short hose on the pump unit is connected to. Once you reassemble the pump unit reconnect the hoses then attach the pump bracket back to the block and reconnect the belt. It is much easier with a socket wrench and extensions. The last two times I have done this I did not have a socket wrench, so it was had to get to the two bolts that connect the bracket to the block. <BR> <BR>One final tip, by two impellers and keep a spare in the boat, just in case. <BR> <BR>Kris

goinboardn 10-03-2005 2:53 PM

This is interesting, i was told by one mechanic to never change the impeller on the water as you are just creating a big hole in the bottom of the boat when you disconnect the hose... didn't sound right to me...

kgd 10-03-2005 8:43 PM

He was right kind of. You need to lift the hose above water level or you will get water flowing into the boat.

espritv8 03-26-2010 2:23 PM

What kind of grease should you use on the impeller? lithim or jigaloo is fine?


All times are GMT -7. The time now is 7:56 AM.