WakeWorld

WakeWorld (http://www.wakeworld.com/forum/index.php)
-   Archive through July 11, 2007 (http://www.wakeworld.com/forum/forumdisplay.php?f=475214)
-   -   4 Wetsounds Pro 60's? (http://www.wakeworld.com/forum/showthread.php?t=464506)

detonate69 06-18-2007 1:50 PM

Anyone running 4 Pro60's? I just picked up 2 sets and will be installing them soon. I have no doubt that with 600 watts going to them they will be incredibly loud.

redv215 06-18-2007 2:53 PM

David...I was looking @ the same setup. Let me know how it turns out...pics?

detonate69 06-18-2007 3:25 PM

I'll let you know. I hope to have them up this weekend. we'll see. I'll post pics for sure.

spencerwakeside 06-19-2007 10:42 PM

I would also like to hear what you think. I haven't heard them yet, but they look great.

bwood 06-20-2007 2:41 AM

Does anybody think two pro 60's on a tower would be loud enough for the rider to here?

stusumm 06-20-2007 5:13 AM

Absolutely! They have the same horn as the pro 80's and two pair powered properly will be plenty.

detonate69 06-20-2007 9:43 AM

I think 2 would definitely be loud enough for the rider to hear....... My motto though is " If you're going to do something, why not overdo it!"

larrys 06-20-2007 1:42 PM

I have 4 Pro60's running and they are definitely load and can be heard by the rider. Check out my install at: <BR> <BR><a href="http://www.themalibucrew.com/forums/index.php?showtopic=9915" target="_blank">http://www.themalibucrew.com/forums/index.php?showtopic=9915</a>

bwood 06-20-2007 3:11 PM

I meant just one pair or two speakers. I'm trying to figure out the total cost for the pro 60's a good amp and install. If someone could help me out with those numbers that would be awesome. <BR> <BR>Pro 60's($800) + Amp(?) + Install(?) = ???

aarond0083 06-20-2007 4:02 PM

Clarion Marine Amp Model APX480M will push out 220 watts RMS at 2 ohms in bridged 2 channel mode. I bought a new one on eBay for my 210 for $140. <BR> <BR>Install will run around $150 to $200 including labor and parts. <BR> <BR>$1200 should be enough to get the finished product.

bwood 06-20-2007 5:22 PM

Thanks Aaron, is that a good amp for those speakers? I know nothing when it comes to this stuff, but I want to do it right. Nice boat Aaron.

aarond0083 06-20-2007 5:41 PM

Thanks. <BR> <BR>I have three of them in my 210. I would day it is a perfect amp for those speakers. And it is made specifically for boats. <BR> <BR>One is powering the four factory rear Polk speakers. One channel for each of the four speakers. <BR> <BR>Another powers the two factory bow Polks with two of the channels. The other two channels are bridged for the factory Polk subwoofer. <BR> <BR>The last one is in bridged, 2 channel mode powering the Skylon Rubicon 250's on the tower. <BR> <BR>Not the best system you can put in a boat but considering I didn't alter the factory system too much, nor did I spend too much additional money I am very happy with it.

jsxstar 06-25-2007 10:00 AM

Just installed 4 pro 60's on my x-star with a memphis 750 watt amp to power them. Tested them out this weekend and they were amazing!! I could here them perfectly clear while riding and they were no where nearly cranked all the way up. The sound quality definitly exceeded my expectations. Gotta give it up to Shane and the guys at Signature Motor Design in Kirkland WA for the great install.

detonate69 06-25-2007 10:35 AM

Well I got them installed but I found some bugs in my system I have to track down before I get the full power of the wetsounds. Went out Saturday morning on Vicky's with only two working and it sounded pretty good. Can't wait to get them all working. I'll post pics after this weekend. We'll be out on the delta all weekend.

pittsy 06-26-2007 8:38 AM

hey JS (jsxstar) can you post some pics of you setup?


All times are GMT -7. The time now is 12:28 AM.