Articles
   
       
Pics/Video
       
Wake 101
   
       
Shop
Search
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME

Statistics
Account Type:WakeWorld Members
Network:Default
Profile Views:3708 profile views
Friends:0 friends
Updated:3 year(s) ago
Signup Date:June 11, 2012
Posts:
396
Points:
Calendar
My Profile
 
About Me
Username:
Truekaotik
Gender:
Birthday:
Occupation:
Home Ride Spot:
My Gear
Board(s):
Inland Surfer, triple X, Hyperlite at this moment...
My Boat
Boat Make:
Centurion
Boat Model:
Avy
Ballast Setup:
Fully slammed...
Stereo Setup:
Wet Sounds and JL..
Options / Accessories:
RGB LEDs everywhere possible....
Tow Vehicle:
2011 AVALANCHE
Recent Activity
2 week(s) ago
Truekaotik made a post in this thread: Stereo issues...... Wetsounds Rev 10/Arc Audio combo
That means the 420 was getting the full, non adjustable signal from the head unit, good job moving it to the front or rear RCAs.
3 week(s) ago
Truekaotik made a post in this thread: Inexpensive Tower Speakers???
From the product listed you already have. I would stay with that caliber and do a pair of WetSounds Icon8 or the JL 8's in their cans. 6.5" will be a bit cheaper BUT I would still do the 8's...
3 week(s) ago
Truekaotik made a post in this thread: Wetsounds Amps in new Supra
Ok I will check it!
3 week(s) ago
Truekaotik made a post in this thread: Headunit and remote compatibility?
Switch it all out with updated equipment :)
3 week(s) ago
Truekaotik made a post in this thread: I'm curious. Tige content.
The hull can be the same design in different size boats, what makes you think they can't? Wether they are or not, it's still very possible. Now unless you are the manufacturer posting or have written proof they are or are not the same, It's a mute...
3 week(s) ago
Truekaotik made a post in this thread: Wetsounds Amps in new Supra
A adapter for the ground is needed and Exile makes it? Huh, Popcorn ready for that one... mike, yeah that's how they are wired in the ones I have done....
3 week(s) ago
Truekaotik made a post in this thread: Stereo problem
If you have a transom remote, It can be a bad head unit or remote. Unplug the remote from the back of the head unit, if the radio works again it's the remote, if it stays, the head unit is bad. We have replaced MANY FUSION head units in Moomba.......
3 week(s) ago
Truekaotik made a post in this thread: Wetsounds Amps in new Supra
Yeah, sorry for the late reply but a relay is needed on the Supra's with touch screen when going WetSounds or multiple amplifiers I have found out. Sometimes it is as easy as you think ;)
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home

 

© 2016 eWake, Inc.
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us