V-drive warning light Log Out | Topics | Search | Register | Edit Profile | User List
Last Day | Last Week | Tree View | Moderators | Help/Instructions
WakeWorld Discussion Board » >> Boats, Accessories & Tow Vehicles Archive » Archive through November 17, 2003 » V-drive warning light « Previous Next »
By Michael Abercrombie (rzmike) on Saturday, September 27, 2003 - 6:28 pm:    Edit Post Delete Post
The V-drive warning light on my Tige 23V came on today. It is always on at idle, but then goes out when the rpm's go up. According to the manual this is normal. However, today the light stayed on. I checked the oil level and it was full so I ignored it. Later in the day I noticed the light functioning normaly again.

After searching the archives it sounds like I might have a oil pressure problem in the V-drive. Anything I can do to fix it short of taking it to a dealer?

 
By ChadB (wantboatnow) on Saturday, September 27, 2003 - 7:46 pm:    Edit Post Delete Post
Check the V-drive oil level, and you may just nees to add a small amount of oil, which I think it 30 weight.
 
By Shawn (csquared) on Saturday, September 27, 2003 - 10:05 pm:    Edit Post Delete Post
If the oil level is correct, it may be the pressure sensor. They go out every now and then causing the light to go on when the oil pressure is fine.
 
Topics | Last Day | Last Week | Tree View | Search | User List | Help/Instructions Administration
Privacy Policy | Terms of Use
WakeSpace is owned by eWake, Inc.
Copyright © 1996 - 2008, All Rights Reserved.
WakeSpace@WakeWorld.com